Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 for Fedora
That did the trick thanks Laugh

Sponsored links

(05-31-2018, 05:14 PM)weirdbeardgame Wrote: That did the trick thanks Laugh

Awesome, glad it's working. I'm glad Fedora fixed their WX package so now we can compile Onepad properly.

(05-22-2018, 03:49 AM)sergiomb Wrote: Used wx3.0.2-gtk2 instead wx2.8
Added BR xz-devel to dectect LibLZMA
Added DISABLE_ADVANCE_SIMD=TRUE, recomended by you
and added OpenGL_GL_PREFERENCE=GLVND to not use legacy OpenGL

and with pcsx2-1.4-8.fc27 this coredump is fixed , I'm waiting for someone to confirm my results.


You seems to be the PCSX2's maintainer of Fedora ?

Sorry, PCSX2 does not work. I have the same problem about gamepad as previous version of PCSX2. I must take a plugin of stable PCSX2 (1.4.0) .

Moreover, with pcsx2-1.4-8.fc28.i686, optimus does not work (nvidia card is not recognized) by PCSX2  only.
Certainly the problem is compilation option below; I have not  the problem with the previous version.

recently, there is an update about optimus on fedora 28.
I can compile (thanks slavezeo for dependencies) commit 54b0edb, it seems to work perfectly but not tested with optimus. I do some tests later.

I cant run any game in PCSX2. I have not used it for months, now it's stopped working.

[Image: Kcoq7OF.png]
I compiled up a piping hot RPM of PCSX2 for Fedora yesterday. It's build 1.5.0 2581 from 10.03.2018. 

Here is the RPM. Install as usual.
PCSX2 1.5.0+git.2581 from my Google Drive.

If interested here is the SPEC file I used to make the RPM.
pcsx2.spec from my Google Drive.
Thanks for all the help so far, I have been able to get the emulator functional with the dnf version in F28!

However, the above PCSX2 1.50+git.2581 completely fails with

Not complaining, just an observation.
(10-15-2018, 09:43 AM)iammik Wrote: Thanks for all the help so far, I have been able to get the emulator functional with the dnf version in F28!

However, the above PCSX2 1.50+git.2581 completely fails with

Not complaining, just an observation.

No complaining taken. Thanks for heads up on it bombing out. I'm not really sure what the problem is exactly. It looks like, from your error, the rpm of PCSX2 uses a newer version of WX than you have installed on your system. Your error reads...

Quote:The library used 3.0 (wchar_t,compiler with C++ ABI 1012,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8).

I may be completely wrong but that's kinda what the error reads. I compiled the rpm on a completely updated install of Fedora 28 on October 3rd, 2018. All I can think of is make sure your system is updated fully, specifically the wxGTK3 packages. If the PCSX2 package you installed via dnf works then you at least have a working version for now. My builds are a bit more current from recent git commits.

I've moved up to Fedora 29 in anticipation of it's release later this month. My future builds will be based on f29. I guess maybe try again when f29 is released. This is not a very good answer but its all I got for now.

Thanks for giving the rpm a go, and double thanks for letting me know about the error.
@slavezeo - Tried dnf update and still same problem. Here's a core dump.

Stack trace of thread 26805:
#0 0x0000000008384663 _ZN8FixedIntILi100EEC2Ed (PCSX2)
#1 0x00000000080d0181 _ZN11Pcsx2Config9GSOptionsC1Ev (PCSX2)
#2 0x00000000080d051a _ZN11Pcsx2ConfigC2Ev (PCSX2)
#3 0x00000000080933c0 _GLOBAL__sub_I__ZN21RecompiledCodeReserv>
#4 0x00000000083abec3 __libc_csu_init (PCSX2)
#5 0x00000000f63f2063 __libc_start_main (
#6 0x0000000008098782 _start (PCSX2)
First off, I've been trying to make my own .rpms to try out the test builds. Big thanks to everyone posting .spec files and posting which rpms are needed for the build.  I think I almost have a working setup, but I might have ran into a bug. (Or did I break something?)

SPU2-X 2.0.0:  When just running 'PCSX2',  everything seems to be work fine.  I can change the settings in spu2 and they save.  But if I use --cfgpath...

PCSX2 /path/to/iso/game.iso --cfgpath="ini/game"

Then I see this in console:

Initializing plugins...
 Init GS
 Init PAD
 Init SPU2
[wx] Failed to create a temporary file name (error 2: No such file or directory)
[wx] can't open user configuration file.
 Init CDVD
 Init USB
 Init FW

SPU plugin still works using default settings, but any changes I do go back to default.  All configurations for other plugins save fine.  As you can guess from the console, there is no 'spu2-x.ini' file in 'ini/game'.  Is this happening to anyone else?

I'm on Fedora 28, currently using PCSX2 build 2930.

**EDIT** Opps, looks like I assumed I only needed the partial path from where it started.  While other plugins had no issue, SPU2-X didn't like that. So i had to change it to:

PCSX2 /path/to/iso/game.iso --cfgpath="/path/to/bash/script/ini/game"

After switching to the full path, SPU config file is now being read/written.

**EDIT** As of build 2977: Also noticed in GSdx.ini:

osd_fontname = /usr/share/fonts/truetype/freefont/FreeSerif.ttf

The closest match in Fedora 28 is:

osd_fontname = /usr/share/fonts/gnu-free/FreeSerif.ttf
Only bringing that up because I don't see anyplace in the GUI to edit it.
so i get it to install and work.. kind of. It cannot initialize my gs system? Is the vega 8 not supported in linux for pcsx2?
amd tr 1950x                                                amd ryzen 5 2500u
asrock x399 taichi                                          amd vega 8 
XFX Radeon rx570                                         16gb ddr 4 2400 ram
32gb gskill ddr4-3200                                    256gb nvme ssd
Windows 10 Pro                                            480gb sata ssd
Custom loop water cooled                               HP envy x360
nzxt 340 case

Users browsing this thread: 1 Guest(s)