PCSX2 (for Netflix)
So I'm trying to do the good old Netflix on Linux work around, but I'm running into some trouble getting the program to work. Running an Alienware m11x on Natty, 32bit, and results have ranged from needing to force kill the program, a blank window with a framerate around 40 fps, and now this latest error, where yes/no/ignore all kill the program dead.

PCSX2 0.9.9.r0  - compiled on Nov 25 2011
Savestate version: 0x9a060000

Host Machine Init:
    Operating System =  Linux 2.6.38-13-generic-pae i686
    Physical RAM     =  3979 MB
    CPU name         =  Genuine Intel(R) CPU           U7300  @ 1.30GHz
    Vendor/Model     =  GenuineIntel (stepping 0A)
    CPU speed        =  1.727 ghz (2 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 0c08e3bd
    x86EFlags        =  20100000

x86 Features Detected:
    MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1

Installing POSIX SIGSEGV handler...
Reserving memory for recompilers...

Loading plugins...
    Binding GS    : /usr/lib/games/pcsx2/libGSnull.so
    Binding PAD    : /usr/lib/games/pcsx2/libonepad-1.1.0.so
    Binding SPU2    : /usr/lib/games/pcsx2/libSPU2null.so
    Binding CDVD    : /usr/lib/games/pcsx2/libCDVDnull.so
    Binding USB    : /usr/lib/games/pcsx2/libUSBnull-0.7.0.so
    Binding FW    : /usr/lib/games/pcsx2/libFWnull-0.7.0.so
    Binding DEV9    : /usr/lib/games/pcsx2/libdev9null-0.5.0.so
Plugins loaded successfully.

(GameDB) 9535 games on record (loaded in 517ms)

/build/buildd/pcsx2.snapshot-4970/common/src/Utilities/Linux/LnxHostSys.cpp(63) : assertion failed:
    Function:  void SysPageFaultSignalFilter(int, siginfo_t*, void*)
    Thread:    EE Core
    Condition: false
    Message:   Unhandled page fault @ 0x00000030

[00] 0x0xb28aa5b2                                
[01] SDL_DestroyWindow                          
[02] 0x0xb287d784                                
[03] SDL_VideoInit                              
[04] SDL_InitSubSystem                          
[05] SDL_Init                                    
[06] 0x0xb286cee4                                
[07] PADopen                                    
[08] 0x0x808ddb3                                
[09] 0x0x8090d5d                                
[10] 0x0x808ea4e                                
[11] 0x0x816982b                                
[12] 0x0x816ac9d                                
[13] 0x0x822879d                                
[14] 0x0x82286df

Any ideas? And would it be better to run the Windows version through Wine for the sake of compatibility?

Sponsored links

I'm not sure what you want to do. But you need to use a real graphics/sound plugins aka spu2x and zzogl (or gsdx-sdl if you built it)

Edit: if you cann't select the plugin you probably miss some dependency.
After monkeying around with plugins, ZZOGL 0.3.0 gives me a stalled program or an error that GS has failed, haven't been able to figure out what the variant is since the first one stopped popping up. While applying GSdx (GCC 4.5.2, SSE2) 0.1.16 [libGSdx-0.1.16], the program immediately kills itself, so that's a bust too. Any other ideas? Tried the stand alone bin and the deb.

EDIT: What I'm trying to do is emulate this method of getting onto Netflix that was being passed around a while back.
You need the spu2x plugins too. By the way, which GPU/drivers. Did a standard game work?
(04-10-2012, 07:28 PM)gregory Wrote: You need the spu2x plugins too. By the way, which GPU/drivers. Did a standard game work?

Got it already. Graphics Card is a Nvidia GT335M, and said disk was the only one I tried. OnePAD too.
Awesome how this is actually the only way to get Netflix on Linux Tongue2
(04-11-2012, 11:50 AM)rama Wrote: Awesome how this is actually the only way to get Netflix on Linux Tongue2

Not quite, you can run a PlayOn server on a Windows box and tunnel into it, but that's... persnickety, to put it lightly. Windows VM is an option, but not quite ideal. Contained solution would be nice, and since Dolphin doesn't have internet capability, and channels don't work that well.

Although, the latest Silverlight beta MIGHT work through Wine, but the numbers aren't out yet. Will check.
I know this thread is really old but has any progress been made on this idea for the newer versions of Linux such as Ubuntu 14.04?

I have an XBMC media center and I have integrated pcsx2 using an add-on called Advance Program Launcher. It would be really nice to be able to have the Netflix iso work for pcsx2 so that people who use Linux can have Netflix support without having to use the wine workaround.

Users browsing this thread: 1 Guest(s)