Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 is not working with my AMD GPU
#1
Hello I am new to this community. Just making a Kingdom Hearts collection. I have a HP Pavilion g6 Series laptop with these specs:
Operating System: Windows 10 Home 64-bit
CPU: Intel Core i5 2410M @ 2.30GHz
RAM: 4.00GB
Graphics: Intel HD Graphics 3000  / 1024MB ATI AMD Radeon HD 7400M Series 
Storage:111GB KINGSTON SA400S37120G (SATA-2 (SSD) / 465GB Seagate ST500LT012-1DG142 (SATA)\

The problem is that when i try to configure my video graphics in adapters option i get only the following options: 
Default Hardware Device
Reference Device
Intel HD Graphics 3000
Microsoft Basic Render Device

When i select open gl renderer pcsx2 seems to recognize my AMD GPU (you can see that in my log) but  it shows some red sentences like an error. Can you tell me a reason why pcsx2 is not recognizing AMD and runs via AMD with direct3d renderers and why when i select direct3d renders pcsx2 automatically runs via intel hd gpu? Thank you in advance!


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#2
you may have to update your amd drivers, i guess.
Still, keep in mind it'll be slow on OGl renderer with this gpu whatever you do
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Also, for AMD cards, you should definitely use DirectX over OpenGL because AMD cards perform really badly on OpenGL for this emulator. Also, you might want to check out the BIOS firmware settings to see if the AMD card is the default card. If there's no such option, update the drivers and make it the default card within Windows.
PC Specs:
PC: HP Omen 15 dc-0051nr laptop
CPU: Intel i7-8750H (2.2 GHz up to 4.1 GHz)
RAM: 16 GB
GPU: Nvidia GeForce GTX 1060 Notebook (6 GB)
OS: Windows 10 Pro (64 bit)/Windows 8.1 Pro (64 bit)
Storage: 256 SSD PCi NV M.2+1 TB HDD
Reply
#4
(12-05-2018, 06:36 AM)gtgamer468 Wrote: Also, for AMD cards, you should definitely use DirectX over OpenGL because AMD cards perform really badly on OpenGL for this emulator. Also, you might want to check out the BIOS firmware settings to see if the AMD card is the default card. If there's no such option, update the drivers and make it the default card within Windows.

I use DirectX but pcsx2 keeps running with intel gpu instead of amd. I tried several times to install new updates but nothing changed. At last i found a way to run pcsx2 to 60 fps with directx and my intel gpu so i can play the games now. Do you think that because my laptop is old windows 10 are not compatible with my gpu specs?
Reply
#5
Quote:you may have to update your amd drivers, i guess.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
DirectX allows you to select the GPU manually, if your OS isn't automatically assigning the right one. That said:

1) Per jesalvein's post, making sure your GPU drivers are up to date is step one. If the latest driver version AMD has listed on their website (I'm an Nvidia guy so I have no idea how/where they distribute their drivers) match that on your system, then you're good here.
2) AMD probably has an equivalent to Nvidia's control panel. Nvidia's control panel allows you to set the default GPU, either system wide or for a specific program. Consider checking this to make sure it's not set to always use your integrated chipset.
3) If all else fails, just select your AMD GPU within GSdx settings.

Friendly reminder, AMD fixed some quality/color/crash problems with OpenGL in their drivers, but has yet to address some serious performance problems they have, so you will want to stick to DirectX 11.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply




Users browsing this thread: 1 Guest(s)