PCSX2 is repeatedly deleting a speciiic game's save file without user input
For the past few months on the 1.7 experimental branch, I've been experiencing a very bizarre but also hard to document issue that could potentially be very harmful depending on where you're from, but there's no way to collect logs for this issue, otherwise this would be going into a GitHub issue instead.

I collect Sly 2 copies, I currently have every region - Sly 1 NTSC, Sly 1 PAL, Sly 1 Japan, Sly 1 Korea, Sly 2 NTSC, Sly 2 PAL, etc.  However, for some unexplainable reason, every once in a while, PCSX2 will automatically delete save data for Sly 2 PAL specifically.  I'd play that release, save my game, double-check that it saved, it would, I shut down the computer without doing anything else, and go to bed.  But when I wake up and boot up PCSX2 again, specifically the Sly 2 PAL save data is gone.  Actually completely gone, if I check the memory card menu in the BIOS, it's gone there too.  I even tried using MultiMC, completely gone.

Now, this would be frustrating if it only happened once, as sometimes save file corruption happens, that's natural.  But this has happened almost 20 seperate, random times and ONLY affects the PAL release of Sly 2, all the other 50+ games in my library, 10 of them being Sly Cooper games of other regions, are completely unaffected by this.  I've checked every possible culprit I can think of - no other games I play share its serial or CRC, no other games I play share its filename, I do run the game with patches but that game's community has been running this game with these exact patches for 3+ years with no issues whatsoever.  As a test I created a completely blank memory card and only played the PAL release of Sly 2 on that memory card - it would still happen, occasionally deleting it which would lead to a blank memory card.

I have no idea why this is happening, I've tried everything under the sun to troubleshoot this, nothing works, and it's so infuriating because I'm using this version in particular for a YouTube series that requires the PAL release.  I don't know what to do, I'm completely baffled how this keeps happening, and I'm the only one that this is happening to.  This made me so worried that I even checked the carbon monoxide detector in my house - no, I'm not carbon monoxide poisoned and mindlessly deleting the save file, this is entirely a PCSX2 issue.  Any advice?

Edit: seems I missed one, a rare case of a matching serial. This was the cause.

Sponsored links

Users browsing this thread: 3 Guest(s)