Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2_keys.ini Location
#1
I want to disable the F12 key so it doesn't popup the video recorder thing since I want to use Fraps instead and I have it set to F12 which works for the rest of my games. I was reading on the wiki I need to change the settings in the PCSX2_keys.ini file but I cannot find it anywhere in my PC. I have PCSX2 v1.2.1 (pcsx2-r5875.exe)
Reply

Sponsored links

#2
it should be in the same directory as the executable file, get the latest development builds from here: http://pcsx2.net/download/development/git.html
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#3
(08-27-2015, 06:19 AM)ssakash Wrote: it should be in the same directory as the executable file, get the latest development builds from here: http://pcsx2.net/download/development/git.html

I looked in C:\Program Files (x86)\PCSX2 1.2.1 folder. I looked in C:\Users\(Username)\Documents\PCSX2 folder. I cannot find this file. I think I download PCSX2 1.2.1 from EmulatorZone or PCSX2 webiste and it was an installer package which I ran and installed all the files. Is this PCSX2_keys.ini file needed to be downloaded seperately?
Reply
#4
No. It is included in the releases. I guess you really downloaded pcsx2 from a untrustworthy source. Just reinstall the latest git or stable release and you will findt the file
Reply
#5
Is the ini file located in C:\Program Files (x86)\PCSX2 1.2.1 folder? and is it hidden from Windows?
Reply
#6
If you used install, INI should be:

C:\Users\Your name\Documents\PCSX2\inis
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#7
@Mrjunky

I did provide you a link for the latest development builds on my first post, get that and you'll have the PCSX2_keys.ini file in the same directory as the executable file, not on the inis folder.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#8
Maybe one should clarify:

The ini is actually not called 'PCSX2_keys.ini' but it is called 'PCSX2_keys.ini.default' and to my knowledge it is always in the parent folder of the ini-Folder (in the folder where you find pcsx2.exe for the portable version and C:\Users\Your name\Documents\PCSX2\ for the installer version).

To activate this ini you have to remove the '.default' in the end 'PCSX2_keys.ini.default' => 'PCSX2_keys.ini' and copy it into the ini-Folder. All instructions are written in the file itsself.



Edit:
To make the whole stuff less complicated I attached the regarded ini-File.
(As the forum doesn't allow files of type .default I just attached another '.txt' to increase the absurdity of file extensions into infinity.)
What you have to do now is:
1. Download my file to your ini-Folder (depending on installation type)
2. Rename it 'PCSX2_keys.ini.default.txt' => 'PCSX2_keys.ini'
3. Follow instructions within the file


Attached Files
.txt   PCSX2_keys.ini.default.txt (Size: 3,46 KB / Downloads: 505)
Reply
#9
I can't get changes to PCSX2_keys.ini to work. I'm using version 1.4.0 on Windows 10; switching back to 1.2.1 didn't help. I made the following change to the default file after renaming it, in an attempt to replace F3 with Page Down:

States_DefrostCurrentSlot         = PAGEDOWN

I also tried it with 'PGDN' and 'KP_PAGEDOWN'. Next I tried setting it to Shift-Tab (and setting the slow motion toggle to F3), and when that failed I tried switching places between F2 and F3, and then I tried to map the defrost-function to ESC and Sys_suspend to PAGEDOWN, but nothing seemed to have any effect whatsoever (Shift-Tab still toggled slow motion, F2 changed the slot, ESC caused Sys_Suspend). I've copied the .ini file to the /inis folder (which I created in the same folder as the .exe, since it wasn't added by the installer). I also tried putting the file in the same folder as the executable and in an '/ini' folder, but nothing seems to work.

The reason I need to change the F3 key to something else (preferably Page Down) is because for some reason my computer refuses to detect it, even though the key itself works fine (I tried physically swapping it with F10 using my keyboard's remapping function, but then the new 'F3' worked while 'F10' didn't, i.e. I was still unable to load saves using the keyboard). Windows seems completely oblivious to the existence of F3. 

Any help would be much appreciated.


///EDIT:

FlatOut Wrote:Did you do what's described in the post above? Copy the "PCSX2_keys.ini" file to the ini folder(possibly the My Documents/PCSX2/ini folder if you used the PCSX2 installer version).

And just to be sure use PGDN code instead of PAGEDOWN.

I somehow missed that part of his post... I assumed the /inis folder should be in the same one as the executable. Thanks for pointing it out, now it works perfectly.
Reply
#10
(05-01-2016, 02:30 PM)VVayfarer Wrote: I can't get changes to PCSX2_keys.ini to work. I'm using version 1.4.0 on Windows 10; switching back to 1.2.1 didn't help. I made the following change to the default file after renaming it, in an attempt to replace F3 with Page Down:

States_DefrostCurrentSlot         = PAGEDOWN

I also tried it with 'PGDN' and 'KP_PAGEDOWN'. Next I tried setting it to Shift-Tab (and setting the slow motion toggle to F3), and when that failed I tried switching places between F2 and F3, and then I tried to map the defrost-function to ESC and Sys_suspend to PAGEDOWN, but nothing seemed to have any effect whatsoever (Shift-Tab still toggled slow motion, F2 changed the slot, ESC caused Sys_Suspend). I've copied the .ini file to the /inis folder (which I created in the same folder as the .exe, since it wasn't added by the installer). I also tried putting the file in the same folder as the executable and in an '/ini' folder, but nothing seems to work.

The reason I need to change the F3 key to something else (preferably Page Down) is because for some reason my computer refuses to detect it, even though the key itself works fine (I tried physically swapping it with F10 using my keyboard's remapping function, but then the new 'F3' worked while 'F10' didn't, i.e. I was still unable to load saves using the keyboard). Windows seems completely oblivious to the existence of F3. 

Any help would be much appreciated.
Did you do what's described in the post above? Copy the "PCSX2_keys.ini" file to the ini folder(possibly the My Documents/PCSX2/ini folder if you used the PCSX2 installer version).

And just to be sure use PGDN code instead of PAGEDOWN.
Reply




Users browsing this thread: 1 Guest(s)