Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 on ASUS K42JC
#1
Hello,

First, I want to start by stating the specs of my notebook computer:

Processor: Intel I3 m370
RAM: 4 GB DDR3
VideoCard:Intel HD Up to 1.7 GB VRAM; Nvidia Geforce 310 M 1 GB Dedicated Vram
HD: 320 GB
Windows 7 64 bit

Now, my problem is everytime i try to open PCSX2, i see that it utilizes the intel HD graphics which I know sucks compared to the dedicated RAM (Geforece 310 M). I am very sure that every driver is properly installed and I have also checked that my default graphics driver is set to Geforce but still, PCSX2 utilizes intel hd graphics every pcsx2 startup. I checked this via the pcsx2 log screen. I just want to ask how could i possibly change the settings so it could utilize the dedicated vram from Geforce. I tried uninstalling the intel hd card so that it could force the pcsx2 to use the dedicated card but it failed since when you uninstall intel hd, nvidia drivers are also uninstalled automatically.

I have tried playing several ps2 games such as harvest moon a wonderful life and digimon world data squad. It's playable but I would want to increase the performance since i usually get fps that are as low as 35 fps. I have tried different settings but still it goes as low as 35 fps.

Please help me :-(. Thanks.
Reply

Sponsored links

#2
you need to add pcsx2 to your Nvidia Optimus

NVIDIA Control Panel--->Manage 3D settings-->Program settings-->Add-->*.exe
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
(01-25-2012, 12:18 PM)tallbender Wrote: you need to add pcsx2 to your Nvidia Optimus

NVIDIA Control Panel--->Manage 3D settings-->Program settings-->Add-->*.exe

Hi Tallbender, Thanks for the quick response.

I have actually tried doing that trick but when i open pcsx2.exe, It still shows that the gs plugin was initiated by the intel hd processor. The plugin should show that it was initiated by Nvidia Optimus right? That's actually what I want to happen. :-(.

Reply
#4
update your optimus drivers.
Reply
#5
(01-25-2012, 03:29 PM)Squall Leonhart Wrote: update your optimus drivers.

Hello Squall, thanks for your tip. It worked like a charm. Nvidia now appears whenever I open pcsx2. However, i was frustrated because the gameplay didnt improve at all. I even think that the performance was much better when I was using the intel hd card. The onlythng i noticed was the crisp graphics. It is playable with Nvidia Card but it remains at 30 to 50 fps only. My aim is at least a constant fps of 60. Is that possible with my rig?

Thanks again.
Reply
#6
Most likely not.

The GeForce 310M isn't much of a GPU.
Try setting the internal res to native.
If need be-- Try entering a custom res of 384x384.
(Note: This will degrade visual quality)
Reply




Users browsing this thread: 1 Guest(s)