PCSX2 on Linux, segfault-ing
Sorry if this is in the wrong place guys, I thought this would be the more appropriate out of "Discussion" and "bug reports".

I'm using the pre-compiled Linux binaries, the line in the console about the version says this:
"PCSX2 0.9.6 - compiled on Feb 28 2009"

I pretty much grabbed the default download, extracted it into a sub directory, ran the program "pcsx2" from the console using "./pcsx2" .
I'm trying to run it without a game currently - just to see how the BIOS screen looks, so this isn't a "game" issue at all (I'm even using the NULL cd driver, so I'd have thought it would be good enough).

I start it up, select a BIOS from the config (and have tried re-selecting just in case) and select "run->execute".
All goes well until it tries to do this section:
EE DECI2 Manager version 0.06 Feb  6 2003 08:38:48

  CPUID=2e20, BoardID=0, ROMGEN=2004-0614, 32M

Segmentation fault

I don't fully understand it.
I've tried using "gdb ./pcsx2" (which causes it to throw out errors about the erom and rom2), and "strace ./pcsx2", which haven't helped me in tracking down the problem.

Everything above it seems fine, with no immediate errors.

I'm using Fedora 10 as my distro, I'm running kernel (with of course the redhat additions).
I use the latest NVIDIA drivers, with an NVIDIA GeForce 9800 GT (512 Megs memory).
I have 3 gigs of RAM, dual core CPU (AMD 4400+), filesystems all have free space (/tmp and /var/tmp are tmpfs's at 768Meg's in size, /dev/shm is also a tmpfs at 512 megs).

I've tried a "-v" parameter but the program doesn't output anything more detailed, and --help just exits before doing anything.

Is there anything I can do to get more meaningful output?
I think I've installed glew, and the nvidia libraries for other applications, plus pcsx2 isn't spitting at me and insulting me about the absence of any libraries.

Any ideas people?
Anything I can do to track the problem down any more?

I can cut and paste examples of my useless gdb and strace output if anyway wants it.

Any help greatly appreciated.

Sponsored links

Do you set-up write permission's for BIOS? Do you have open-gl devel installed? What was gdb output?
Moved to general discussion

Users browsing this thread: 1 Guest(s)