PCSX2 running REALLY slow
Hi guys, I'm "new" in this forum, (I follow it by somehting like 4 years though), and I'm having a big trouble with the emulator. 
I tried several versions, from 0.9.6 to 1.5.0 DEV. 
None worked so far. 
I'm pretty sure it's not a configuration error. The problem is that whatever game I run, I get HUGE framerate drops. 
I have all the speedhacks disabled, but enabling them won't change anything.
I tried using GSDX with DX10, DX11, DX9 and OGL (obv in Hardware mode) and I always had the same results. 
My PC config is really good, it's really weird cause I can run GTA 5 in 4k at nearly 60FPS, lol. 
Fun fact: choosing Native, 2x, 3x, 4x or any custom resolution will affect only the quality, but the framerates will be almost the same. (I thought that resolution scaling could cause  even more FPS loss).
I'm having this problem till I upgraded my PC hardware (from 3770k to 6700k, changed motherboard from z77 to z170, changed RAM from 8GB DDR3 to 16GB DDR4, same GPU), and did a fresh install of Windows 10.
Before this, i was using Windows 7 with that old config, and I had MUCH higher framerates, even on my old HD 5850, even on 4x scaling. 
I have the same problem with other emulators, if it helps (Dolphin, Higan, CEMU).

Full Config:
CPU: i7-6700k @4,4GHz
GPU: Sapphire R9 280x TOXIC 3GB OC
RAM: 16GB HyperX DDR4
Motherboard: ASUS ROG Z170 Maximus VIII Hero
SSD: Samsung 850 Pro 500GB
HDD: 3TB WD Black + 1TB WD Green

Sponsored links

Sounds like your i7 is speed-stepping. Try running CPU-z ( http://www.cpuid.com/softwares/cpu-z.html ) along with PCSX2 and check the frequency of your processor while getting the frame drops
[Image: newsig.jpg]
In power settings for windows, are you set to performance? I'd run something like cpu-z and see what temps you're seeing on the proc to see if you're throttling like Bositman suggested as well.

Hardware wise you're definitely spec'd to run most everything.. but I think there still a few game that cause problems. Here are a couple of things I noticed when I went to win 10...

Every once in a great while, my windows install would update the drivers using the Microsoft drivers, and they just NEVER performed as well.. I'd go and install the NVidia drivers and I'd see boosts in frame rates across the board. I'm assuming AMD has the same type thing going on...

Before refraction pops in and asks.. Mind posting your EMU log to see if there is anything suspicious in there? Also, while your at it.. what games are you seeing the fps drop in?

Do you experience any issues without the OC on the proc?
amd tr 1950x                                                 amd ryzen 5 2500u
asrock x399 taichi                                         amd vega 8 
XFX Radeon rx570                                       16gb ddr 4 2400 ram
32gb gskill ddr4-3200                                   1tb nvme ssd
Debian Bullseye                                           480gb sata ssd
Custom loop water cooled                           HP envy x360
nzxt 340 case
Well, I had the issue almost everywhere.
I solved it just by disabling Hyper-Threading.
Almost no difference in daily use, and solved the issue.
I didn't notice any frequency drop when i had those FPS drops, so it wasn't a SpeedStep issue I suppose (disabling speedstep disables turbo boost aswell).
Hope this helps users that have the same issue.
Now i can do 60FPS on 8k native res and nearly 50FPS on CEMU.

Users browsing this thread: 1 Guest(s)