PCSX2 streaming issue
Hey Forum,

Decided to post here because I'm pulling my hairs out trying to solve this issue. Worst part is that I've been working in IT for 5 years now and this is the thing that 'kills' me Laugh.

I have PCSX2 setup at my home PC and turned my PS2 games into ISO's. via IMGBURN.
I have downloaded SCP to enable my PS3 controller to play these games properly.

When I plug my PS3 controller into my home computer, everything works fine, without issues.
Now I learned about emulation station and decided to turn an old laptop into an thinclient for my TV. As you can expect, this old laptop is not strong enough to play PS2 games on it.

Therefor I decided to stream games via STEAM for ease of access.
I downloaded and installed emulationstation for a quick way to boot games and not mess with CLI commands.

The problem that I'm facing, is that whenever I press the circle button, PCSX2 seems to close and fills the screen with the blue starting window. (where you can select system, cdvd, config, misc, debug). This means that any game I play, the moment I press the circle button, it stops.

To make sure, that emulationstation is not the cause, I added pcsx2 with CLI command directly to the steam library, and booted up the game. I still receive the same issue.
Then I wanted to know, that this maybe is something of steam / emulationstation, so I decided to download a NES emulation and download (yes yes I know, not allowed, strictly for testing purposes, although I do have a legit NES w/ super mario bros 3 lying next to my TV (retro Laugh) and streamed it via steam > emulation station. The circle button works and acts like it should.

So it is PCSX2 which is causing this issue. I tried to recreate the binds for the controller, but to no avail.
Has anyone encountered such an issue or knows a way to solve this?

Thanks in advance.

Please note that I plug my controller in my laptop 'thinclient'. Because I have my controller hooked up on another computer, this issue happens.

*Edit 2*
It seems that pressing the circle button, closes all plugins.

Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.

Sponsored links

That happens when you close the game window
Try adding --fullscreen and --nogui command lines and maybe as a last resort --noguiprompt
(01-18-2017, 11:38 PM)vsub Wrote: That happens when you close the game window
Try adding --fullscreen and --nogui command lines and maybe as a last resort --noguiprompt

This solved the issue.

I even added --fullboot for nostalgia.

Thanks Smile

Users browsing this thread: 1 Guest(s)