Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCX2 running games at 50% speed
#1
Hello, I have been using PCX2 for the past couple of weeks and it has been working well for the most part, but recently games like NCAA Basketball '09 have been running at 50% speed. My specs are i7-8750 processor with NViDIA Gefroce GTX 1060, so I feel that my hardware is up to snuff. My PCX2 version at the moment is pcsx2-v1.5.0-dev-2487-gc695d6a3a, which was working fine until I got the reduced speed yesterday. I also have the MTVU cheat enabled atm, and setting PCX2 to use my NVIDIA graphics card is still giving me slow speeds. I also tried togglign slow motion on and off and the speed does not change.
Reply

Sponsored links

#2
If you see Slowmo in the game window titlebar,press shift+tab(this is a combination to enable\disable slow motion which sets the speed to half speed)
Edit: I did not read the last line from your post
Do you get exactly half speed,what does the ee,gs and vu say in the title bar
Reply
#3
Also if this is a laptop with GeForce Experience, make sure you are plugged in to AC power. There is a battery boost that hard caps FPS at 30.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#4
(08-23-2018, 05:51 AM)vsub Wrote: If you see Slowmo in the game window titlebar,press shift+tab(this is a combination to enable\disable slow motion which sets the speed to half speed)
Edit: I did not read the last line from your post
Do you get exactly half speed,what does the ee,gs and vu say in the title bar

It is typically around 49%, sometimes 51%, and the ee/gs/vu is 12-20/0-5/0-5, as it tends to vary.  I think its based around the geforce thing as the user below stated, as when I plug it in I shoot back up to 100% speed. Any idea on how to turn off that setting?

(08-23-2018, 03:54 PM)pandubz Wrote: Also if this is a laptop with GeForce Experience, make sure you are plugged in to AC power. There is a battery boost that hard caps FPS at 30.

How do I turn off battery boost?
Reply
#5
(08-24-2018, 02:21 AM)nebularthm Wrote: How do I turn off battery boost?

It should be under the GForce Experience program, but sometimes it is not in a driver due to improper installation and sometimes it just is not there on some models, so if it is not there try unistalling then reinstalling both your Display drivers and GForce Experience (if you have updates available try that first since it is quicker and might fix it as well). The setting should then be in GForce Exoerience for you to turn off. It will probably be called set frame rate target and you can just uncheck it. Keep in mind it exists for a reason and doing this will kill your battery life since your laptop has a powerful graphics solution that will happily drain your power very fast.
Reply
#6
Battery boost only engages when you are running on battery. So the simple solution is to keep your laptop plugged in to AC power.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply




Users browsing this thread: 1 Guest(s)