PS2 to USB Controller Issue

Okay so, I downloaded PCSX2 and copied a game iso, and it runs so far fine but i cant go far because it isnt recognizing my controller. at first I thought it was PCSX2 but, I am not sure now. When I went to the Devices in windows, it sees the controller and says it works fine but I cant seem to calibrate it or recognize when i push buttons.. it kinda makes me feel Windows isnt working with it well and so PCSX2 isnt as well.

Has anyone discovered this issue before?

Sponsored links

No but try using Lilypad and check Direct Input in both the options
Intel E5700 @3.0Ghz,
Xfx Radeon 5670 1Gb,
4Gb DDR3 Ram,
Microsoft Windows7 Ultimate x86
Hm.. okay i tried what you suggested.. making sure direct input is on and using lilypad and it still wont register anything. Sad
What I did to get my gamer pad working was in lilypad under the pad1 tab I set up the controller the way I wanted and then selected "Windows messaging" under mouse API. If i selected "DirectInput" the the pad wouldn't work at all. If you using vista I suggest running as an administrator if you UAC turned on (it is by default) and selecting "Windows Messaging". Best of luck.
thank you.. i tried that also but still ti wont see the controller. But again I dont think windows really is either.

could it be an issue with libusb? i saw that somewhere.
I'm not sure about libusb. One thing to try is under lilypad general see if you can test the device. Wiggle the sticks around and if your z,y, and x values are changing then your device is at least being recognized and there could just be issues with some settings for the games. However if its not showing up or you cant change any values it could be that windows is indeed not recognizing it. All I can suggest there is to test a few different usb ports (docking station ports don't work so well in vista and 7 so try using usb's in the back of your computer). You might also want to make sure any drivers you need for the device are installed correctly. Sorry I couldn't be more help. I'm very new to PCSX2 as well but I thought I could at least give you something to try.
Hey, i had just exactly the same Problem with my ps2-to-usb. You know what turned out to be the problem? This picture describes best, i think.

Just blow every cable end as well as your USB input.
hm.. nothing seemed to work, i did come across another forum that mentioned that it could be because it is a 32 bit driver and im running 64 bit.
Then download the 64-bit driver.................
Intel E5700 @3.0Ghz,
Xfx Radeon 5670 1Gb,
4Gb DDR3 Ram,
Microsoft Windows7 Ultimate x86
Yeah...libusb is only compatible with 32-bit systems. Use motionjoy when running a 64-bit system. Here:

Its a bit complicated to install, but its the only 64-bit compatible controller driver that I know of.

Users browsing this thread: 1 Guest(s)