Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PS4 Controller, no audio
I downloaded and started playing PCSX2 a couple months ago and I've been using a PS4 controller the entire time.
I remember when I first started playing on it, it would detect and use the controller itself as an audio output, so there would be no sound (it also detected the controller as a mic, so I had to unplug the controller if I wanted to use my actual mic, which I can live with). I eventually fixed it and I don't remember how. 

I just got back home after being away for a month, and I found the controller I was using and started up PCSX2 again. I have a USB port on my keyboard (roccat ryos mk pro) and it used to work fine with the controller but now the controller itself doesn't work with that port (but there is sound). I then used the first port on my computer tower and the controller worked, but no sound whatsoever in PCSX2 or on my desktop. Same with the second port on the tower.

I tried changing the audio module in PCSX2 from DirectSound to XAudio 2, didn't work. XAudio 2 to PortAudio, didn't work.

I checked the PCSX2 site and I can't find an update so I think I have the most up-to-date version, 1.4.0 . I also use Windows 10.

I'm at a loss for what to do, and while I'm pretty good with computers I just can't figure this out. Help would be appreciated. 


Sponsored links

Users browsing this thread: 1 Guest(s)