Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PS4 controller stops being recognized once game loads
#1
Im using Lilypad and 1.4.0.

When I first open PCSX2 it recognizes the controller in Lilypad. When I hit test device for DX Wireless Controller, it shows the input values and responds to the sticks being moved and the buttons being pressed. Once I actually start the game up however, the controller does not work. Checking the Lilypad settings at this time reads all of the values being blanked out, and does not respond to buttons being pressed. Unsure how this could be happening.

I know the controller works with the PC because of the test results above, plus with DS4Windows running, I can use the touchpad for Mouse control. The issue seems to be with PCSX2 specifically when a game is running.

I've tried DS4Windows and also Scarlet Crushes XInput wrapper. Nothing has worked yet. Any advice?
Reply

Sponsored links

#2
So I've done more testing and the issue seems to occur precisely when a DVD is loaded through pcsx2? I've tested versions 1.4 and a recent developments build 1.5. I've also done a complete reinstall of 1.4. Tested with multiple ISOs, the same behavior happens in each.

The controller will, upon an ISO being loaded, lose connection to ds4windows/ds4 input wrapper 1.22 (tried both under all 3 setups listed above). Also tried running the ds4 under direct input instead of xinput, no difference. Controller will stop responding immediately.

Tested controller on a different PC, under 1.4 and using ds4windows and the controller worked there. At this point I'm running out of ideas. It can't be the controller, the cord, or the PC itself because as stated above the controller works in other applications, but stops responding when an ISO is loaded in pcsx2. Controller works with pcsx2 on another PC. It's only on this one PC that this happens. If anyone has any advice I would greatly appreciate it
Reply
#3
or perhaps the ps4 controller "when bluetoothed" was idled for 5 minutes it was auto-disconnected....then...you need re-connect and re-run the emulator.
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#4
The controller is connected via USB, not Bluetooth. Also, the behavior is highly reproducible and will occur at any time that the ISO is loaded. If you have PCSX2 on one monitor and ds4windows/input wrapper on the other, you will immediately see the "Controller 1 has been disconnected" message appear as soon as the ISO starts loading.
Reply




Users browsing this thread: 1 Guest(s)