Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pcsx2 1.4 suddenly drop speed, but worked before...
Hello anyone,
Forgive my post, i've made sure to read abput your FAQ and spec speed, still, i have a vivid memory of my pc, on a previous format, running emulation for, at least Dark Cloud 1, at almost 100%.
Now, whenever i turn on my pc, and quickly start emulating it, the game actually reach 100%, but after 4-5 minutes of play, it drops to 50-60%, and nothing i do makes it go back up. I think I'm forgetting something, as it actually works for a bit, for every game i own, but quickly drop to that fps rate no matter what i emulate.
My specs are:
Windows 7 x64
Amd athlon II x4 2.4Ghz
Nvidia geforce gt610 2gb, shaders 2.0
6 gb ram ddr3

Sponsored links

Your processor is nearly half of the recommended minimum to run lighter games . (834 str vs the 1600-2000 recomended str)

So 50-60% seems to be right around where the performance should fall. That being said, maybe you were using an older version of PCSX2 that was less accurate with less CPU performance needed. You could also try messing with some of the speed hacks, but with your performance deficit I don't know if any of them will do much more then introduce other issues.
Then why do i get 100% at the beginning, with every kind of game?
You're lucky, but we can't offer much support when your CPU just isn't up to the task. If it worked, then great, but it running slow is what you should expect. Honestly you need to either upgrade your CPU or use the original PS2
Windows 10 64 bit OS
Intel Core i7-6700 3.4 GHz
Geforce GTX 1060 3GB
Still don't understand why it worked before, I'll try older versions, plus "lucky" shouldnt apply on computers, and to be honest, it's the third time i register, third time i ask for help, and third time i get the same answer, i think this is getting pointless both ends.
True. You keep getting the same answer, it's pointless to keep asking the same question. Everyone here will tell you the same thing. Your CPU is just to weak. Chalk it up to what you want, but that's not going to change
Windows 10 64 bit OS
Intel Core i7-6700 3.4 GHz
Geforce GTX 1060 3GB
No, it's not that, the first time i asked, long ago, for a fix in suikoden tactics, as i saw too foggy and inivisible characters, and people said "weal cpu", yet with a game fix for another game it worked; second time, i needed help for disappearing terrain in disgaea2, yet again, " weak cpu" as answer, still on here, and again, i found out on my own how to fix it, as i had a broken gpu driver, with windows registry problems, so i formatted and reinstalled, all good. What i was asking is: i know it works, but I'm sure something is slipping my mind, as by tweaking a bit more i managed to send dark cloud 1 to 72% just now. So i would like to know: what should i check? C++ redist? Drivers? Hacing "low cpu" didnt stop me from running dragon age inquisition at high spec, wont stop me now.
It starts out at 100% speed when the game starts up for a few reasons

1. Not as much of the game's code is loaded up and running thus lighting the load on the CPU

2. The CPU has not been pushed to the limit for a long period at that point (less heat build up), and if you do not have a very good cooling system then your system is also possibly throttling (you are not even getting full performance then as the CPU tries to protect itself from damage). This can become worse over time if you do not clean (physically clean) your system and in particular your cooling system (fans, heat sinks, air vents and general dust in the case)

3. You are right that luck does not factor into general PC performance and if you can get everything (drivers, programs, OS state, cooling performance, ambient temperatures, hardware performance [in case of degradation over time, rare but can happen], and everything else missed here) to the exact same state as before then a program should preform the same. Otherwise you have to trouble shoot and figure out what has changed and revert that change (if you can) to see what caused the loss of performance. I gave you the most likely cause first which is using an older less accurate version of the emulator, if that is not the case then your will have to slowly revert each change you did to figure out the issue.
Thank you TKSilver, that was a magnificent answer, this makes a lot of sense, now i remember! I used to have this nice function i made to automatically shut down all the processes not needed by the emulator, and turn them back on when i close it, that is what i was forgetting! Finally after 12 years a real answer! Thank you very much!
only thing i can think of is you adjusted to many speedhacks or you did something with your system like the power plan for example its all down to your CPU at the end of the day try downloading the latest 1.5.0 dev build they have been improved so much over time compared to 1.4.0.

Users browsing this thread: 1 Guest(s)