Pcsx2 & Xbox one wireless controller + Windows wireless Adapter
I been having problems configuring my Xbox one wireless controller with the new wireless adapter for windows,
is basically impossible to configure it correctly, Lilypad plugin just wont configure correctly, it took me over
20 minutes to get a configuration that i want it after pressing clear many,many times totally painful to do it.
after i thought i had the configuration since i been trying for a while i try it on Marvel vs Capcom 2 to notice that
A & B that equals X & circle were not working since L2 & R2 are like not letting X & circle to work they are conflicting
with each other, once i delete the entry of L2 & R2, X & O start working again, if i try to re configure L2 & R2, X & O
stops working so no way to configuring this buttons, please developers if you can get the new windows wireless adapter
for the Xbox one controller try it on Pcsx2 you will see that it takes a lot of time to configure it. and if anyone have any
clues on how to make it work please feel free to help me. thanks in advance.

Sponsored links

Confirmed, I'm having exact same problem with xbox wireless, buttons are muddled when
configuring in lillypad, I can only assign about 10 buttons, they seem to write over each other,
hope there's a fix, maybe windows drivers.
You can try to disable dinput. Maybe there is some collision. Does the 'test device' dialog show expected results?
Worked perfectly after I disabled it (Direct Input)! Thank you. You're my hero Laugh
(12-22-2015, 12:45 AM)Sir.Meow_Meow Wrote: Worked perfectly after I disabled it (Direct Input)! Thank you. You're my hero Laugh

Do you mind elaborating?

I'm trying to make my Xbox One controller work through the wireless adapter, but I think I'm having the same issue you ran into to begin with. In the configuration for the controller, Device Diagnostics -> Test Device on my "DX Controller (XBOX One For Windows)" shows all the right inputs. But when I try to map the controls, many different buttons register as the same PC Control of "Z Axis -".

I tried what you did and unchecked DirectInput under the General tab for LilyPad Settings, but that seems to disable the controller entirely.

Any help would be great! Thanks!

Edit: I figured out what went wrong. Some settings in my computer were already changed when I tried to get my controller to work with the steam version of FFXIII, so I had to go back and change some of those. In Device Manager, under Human Interface Devices, I believe the wireless Xbox One controller defaults as "XINPUT Compatible HID Device". I had previously changed that device to "HID-compliant device" to try and make it work in FFXIII. I had to change it back to make it work in PCSX2. To change it back, I had to right click on "HID-compliant device", Update Driver Software, Browse my computer for driver software, Let me pick from a list of drivers on my computer, and then choose the option for "XINPUT Compatible HID Device".

Now, when I go into PCSX2, i uncheck the box next to DirectInput in the config settings for LilyPad, and that'll let me map the controls for my wireless controller.

Users browsing this thread: 1 Guest(s)