Pcsx2 does not go beyond game intro

I downloaded and installed the pcsx2 emulator, I configures the necessary things, and tried running A game (star trek racer revenge , CD ISO), however the game intro shows up, but then nothing after that, no game menu etc.

Can anybody help, This is my config, Inter Core 2 Duo 2.00Ghz, No graphics card, bios is USA v2.00 14/06/2004.

also let me know if i need to post any more info.


Sponsored links

maybe beacuse you dont have any graphics card??? lol,that game maybe is not yet supported by the emu,have you tried running it on software mode??,also grab the latest beta from here http://forums.pcsx2.net/thread-8317.html
[Image: 2ymccqu.jpg]
[Image: 17715.png]
Very specific BIOS name..
But check the compability list, and you have a GPU, otherwise you wouldn't get a display, maybe not a card as such.
AMD Phenom II 940 @ 3.6GHZ, 4GB PC8500 @ 1100MHZ, 4870x2 @ Stock.
Wrong place to post. Moved.
(01-31-2010, 07:28 AM)gigaherz Wrote: Wrong place to post. Moved.

try running a game that is full playable (u can see it at the main site) and use r1888

if u still got problems try telling us about the pcsx2 settings u use
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
(01-30-2010, 08:41 PM)Sythedragon Wrote: Very specific BIOS name..
pcsx2 displays that info in the config screen..

Users browsing this thread: 1 Guest(s)