Pcsx2 error message.

i have an issue with the emulator that i just cant seem to find the answer to. I have looked at the faq/setup etc. But there doesnt seem to be an answer there.

The message i get is: GS plugin failed to open. Your computer may have insufficient resources, or incompatible hardware/drivers.

Now.. i have used pcsx2 before, and have never gotten this problem.
to me it seems like the newer releases have broken it for me.
any help would be appreciated.

QUICK EDIT: i am using the 1.1 release as the setup guide told me to use. but i have also tried the 1.2.1 release with the same result.

PCSX2 1.1.0.r5766 - compiled on Dec 19 2013
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 8183 MB
CPU name = Intel® Core™ i7 CPU 870 @ 2.93GHz
Vendor/Model = GenuineIntel (stepping 05)
CPU speed = 2.942 ghz (8 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0098e3fd
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Reserving memory for recompilers...

Loading plugins...
Binding GS: D:\PCSX2 1.0.0\Plugins\gsdx32-sse2-r5350.dll
Windows 6.1.7601 (Service Pack 1 1.0)
Binding PAD: D:\PCSX2 1.0.0\Plugins\lilypad-r5350.dll
Binding SPU2: D:\PCSX2 1.0.0\Plugins\spu2-x-r5350.dll
Binding CDVD: D:\PCSX2 1.0.0\Plugins\cdvdGigaherz.dll
Binding USB: D:\PCSX2 1.0.0\Plugins\USBnull.dll
Binding FW: D:\PCSX2 1.0.0\Plugins\FWnull.dll
Binding DEV9: D:\PCSX2 1.0.0\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9645 games on record (loaded in 192ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
Init PAD
Init SPU2
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
AMD Radeon HD 7900 Series (
* SPU2-X: Enumerating PortAudio devices:
*** Device 0: 'Primar lyddriver' (Windows DirectSound)
*** Device 1: 'Hoyttalere (VIA High Definition Audio)' (Windows DirectSound)
*** Device 2: 'Line 1 (Virtual Audio Cable)' (Windows DirectSound)
*** Device 3: 'Line 2 (Virtual Audio Cable)' (Windows DirectSound)
*** Device 4: '1 - BenQ G2222HDH (AMD High Definition Audio Device)' (Windows DirectSound)
*** Device 5: 'Digital Output Device (HDMI TX0) (VIA High Definition Audio)' (Windows DirectSound)
*** Device 6: 'Oretelefon (Logitech F540 Headset)' (Windows DirectSound)
*** Device 7: 'SPDIF Interface (TX1) (VIA High Definition Audio)' (Windows DirectSound)
*** Device 8: 'Line 1 (Virtual Audio Cable)' (Windows WASAPI)
*** Device 9: 'Line 2 (Virtual Audio Cable)' (Windows WASAPI)
*** Device 10: '1 - BenQ G2222HDH (AMD High Definition Audio Device)' (Windows WASAPI)
*** Device 11: 'Høyttalere (VIA High Definition Audio)' (Windows WASAPI)
*** Device 12: 'Digital Output Device (HDMI TX0) (VIA High Definition Audio)' (Windows WASAPI)
*** Device 13: 'Øretelefon (Logitech F540 Headset)' (Windows WASAPI)
*** Device 14: 'SPDIF Interface (TX1) (VIA High Definition Audio)' (Windows WASAPI)
*** Device 15: 'Output (AMD HD Audio HDMI out #0)' (Windows WDM-KS)
*** Device 16: 'SPDIF Out (HD Audio digital out)' (Windows WDM-KS)
*** Device 17: 'Output (HD Audio HDMI out)' (Windows WDM-KS)
*** Device 18: 'Speakers (HD Audio rear output)' (Windows WDM-KS)
*** Device 19: 'Line Out (Virtual Cable 1)' (Windows WDM-KS)
*** Device 20: 'Line Out (Virtual Cable 2)' (Windows WDM-KS)
*** Device 21: 'Øretelefon (Logitech F540 Headset)' (Windows WDM-KS)
* SPU2-X: PortAudio error: Invalid device
Opening CDVD
isoFile open ok: C:\Users\Sparre\Desktop\Shin Megami Tensei - Persona 4.iso
Image type = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2151344 sectors)
Opening USB
Opening FW
Opening DEV9
AMD Radeon HD 7900 Series (
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
(pxActionEvent) GS plugin failed to open!(thread:MTGS)(thread:EE Core)
Closing PAD
Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
Path: D:\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll
File is not a valid dynamic library.
Some kinda plugin failure: D:\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll
User-canceled plugin configuration after plugin initialization failure. Plugins unloaded.

Sponsored links

update directx ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
I have done that as well. Even several times to be sure.
First it looks like your SPU2 Plugin is breaking. This is probably not the main issue, but it can't hurt to fix it. Config->Audio->plugin settings. Change PortAudio to Xaudio or Dsound.
[Image: XTe1j6J.png]
Gaming Rig: Intel i7 6700k @ 4.8Ghz | GTX 1070 TI | 32GB RAM | 960GB(480GB+480GB RAID0) SSD | 2x 1TB HDD
I have managed to fix it.
I redownloaded the 1.2.1, changed sound plugin to xaudio (noticed you wrote that as well Smile ) and set my gs plugin settings to direct3d11.

Thanks for your help anyways Laugh
By the way, you can use GSdx SSE4 for a little speed boost, your GPU supports that.
Intel Core2 Duo T5450 (1.666 GHz)
[Image: gzztty.png]
Mobile Intel® 965 Express Chipset Family (500 MHz)
GPU-Z Validation
RAM: DDR2-666 (2 GB)
Not a gaming PC, but I'll try to get a better one in the future.

Users browsing this thread: 1 Guest(s)