Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pcsx2 on Ubuntu 11.10 64 bits. CDVD plugin failed
Hello, i bought a new brand computer with a core i7 2600 and a motherboard with the intel integrated graphics HD 2000. I installed Ubuntu 11.10 on it, cuz I have 8 Gb of RAM. I follow this: of course adjusting that for oneiric and so on, and all the installation work perfectly. The problems came later, when i wanted run the FFX through an Iso. I get this error "CDVD plugin faild to open. Your computer may have insufficient resources, or incompatible hardware/drives." then the error recomend me to adjust the CDVD plugin option but when i do that i get this error Warning! System Have Not Been Loaded plugins. PCSX2 May Be inoperate. I am sure that its not that my pc have insufficient resources, and i really doesnt like to have to install Wintendo to play. Help me please!!!!!

PS: Excuse me for my defficient english, but i am not a native speaker english

Sponsored links

Please copy past the output of PCSX2 from a terminal. Hum I'm not sure that your "GPU" can support PCSX2 (driver limitation).

Which build do you run? Can you use this build:

For the plugin configuration,
gs (zzogl (need ogl 3.0) or gsdx)
spu (spu2x)
pad (onepad)
others (null including cdvd)
Well, the problem is that i am not in my personal pc right now. But how i coul install that on my 32 bit chroot? Should i have to uninstalled the that i installed from the svn acording to this:
Did you compile from svn (cmake, make and co) or did you download a tar ball from ?
Yes i compiled from svn i followed this

svn checkout .pcsx2-read-only

cd .pcsx2-read-only/


make install

And i call the pcsx2 like this:

xhost +LOCAL:
schroot -c oneiric_i386 -u root

export DISPLAY=:0.0
sh home/rcarmona/bin/

There are my ouput from the pcsx2 terminal

PHP Code:
PCSX2 0.9.9.r4990  compiled on Dec 16 2011
Savestate version

Host Machine Init
Operating System =  Linux 3.0.0-12-generic i686
    Physical RAM     
=  7911 MB
    CPU name         
=  Intel(RCore(TMi7-2600 CPU 3.40GHz
/Model     =  GenuineIntel (stepping 07)
CPU speed        =  3.389 ghz (8 logical threads)
x86PType         =  Standard OEM
=  bfebfbff 1fbae3ff
=  28100000

x86 Features Detected
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

'English (U.S.)' [] is not supported by the operating system
Installing POSIX SIGSEGV handler
Reserving memory for recompilers...

Loading plugins...
Binding GS    : /home/rcarmona/.pcsx2-read-only/bin/plugins/ 
    Binding PAD    
: /home/rcarmona/.pcsx2-read-only/bin/plugins/ 
    Binding SPU2    
: /home/rcarmona/.pcsx2-read-only/bin/plugins/ 
    Binding CDVD    
: /home/rcarmona/.pcsx2-read-only/bin/plugins/ 
    Binding USB    
: /home/rcarmona/.pcsx2-read-only/bin/plugins/ 
    Binding FW    
: /home/rcarmona/.pcsx2-read-only/bin/plugins/ 
    Binding DEV9    
: /home/rcarmona/.pcsx2-read-only/bin/plugins/ 
Plugins loaded successfully

GameDB9535 games on record (loaded in 178ms)
HotSwapping to new ISO src image!
HLE NoticeELF does not have a path.

Initializing plugins...
Init GS
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully

Opening plugins...
Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
CDVDiso Error
No filename specified.
Closing plugins...
Closing SPU2
    Closing PAD
    Closing GS
Plugins closed successfully
Shutting down plugins...
pxActionEventCDVD plugin failed to open!(thread:EE Core)
Plugins shutdown successfully

Change the cdvd plugin to cdvdnull (pcsx2 have a built-in that read iso). And for the sound plugin use spu2x not zerospu2.


hmm, ok, i will try later when i arrive to my home and i´ll put the result here. Thanx!!!

/To Gregory, i tried that you recomend me and doesn work, still the same error, any other suggestion?
Add this cmake flags -DFORCE_INTERNAL_SDL=TRUE (then rebuild with make)
It would build a new GS plugins that might work better with your GPU.
Gregory you are a genius, i did that and when the plugin GS it work perfect, like i were playing on a PS2. Now i need to find out if a PS2 joystick work on ubuntu, or a gamepad for PC, i dont know if that gamepad are the same button of the normal PS2 joystick, i mean circle, square, triangle and equis in the gamepad for pc are 1,2,3,4. How can I match them? will work on ubuntu? I think that i better open a new thread.

Users browsing this thread: 1 Guest(s)