Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pcsx2 running slow
#1
Hi to all, im looking for some advice, after previously attempting to run pcs2 on an i5 laptop, i gave up and managed to get a decent second hand pc, however despite the extra beef its still running really slow even at basic settings , i also use dolphin which runs very well, so im a bit confused az to why pcsx2 wont run correctly
 
Specs
Core i5 650 [email protected]
6gbRam
Nividia geforce gt 220 128bit 1gb (nividia percormance settings tweaked above factory settings)

I'd appreciate any help as im totally confused, i have friends with slightly weaker hardware running it no problem. Its a shame because i have a heap of ps2 discs id love to play again. 

Ps i am aware that running physical discs can cause a slow down. And have addressed this yet it still runs slow
Reply

Sponsored links

#2
What version of PCSX2 are you using, and do you have any non-default settings enabled?
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#3
(12-14-2017, 02:59 AM)pandubz Wrote: What version of PCSX2 are you using, and do you have any non-default settings enabled?

Im using the latest version, as far as i can tell everything is default not using anything that might slow it down. Using native ps2 resolution, i didnt want to push it too hard on first run.
Im using sse2 and direct9
Reply
#4
try ssse3 or sse4.1
what windows version you are using?
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#5
(12-14-2017, 03:16 AM)smartstrike Wrote: try ssse3 or sse4.1
what windows version you are using?

Im on windows 10 home
I tried sse3 and 4 already
Doesnt run at all with those
Got a gut feeling something with the pc is off not the emu
 Cheers
Reply
#6
that video is very low-end considering change that nvidia card with the suffix model number of 5 or above....e.g. x5x,x6x,x7x and x8x models
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#7
stock that cpu has a stp of 1350ish.. I dont know what you're seeing with that oc.
They recommend 1600-1800 to run most games.. where do you bench at using passmark performance test?

That video card is really not any better than the Integrated graphics on more recent processors.. up that to a gtx 750 ti oc and you'll probably have a pretty good performing rig.. IF your chip benchmarks well enough...
amd tr 1950x 
asrock x399 taichi
XFX Radeon rx570
32gb gskill ddr4-3200
Windows 10 Pro
Custom loop water cooled
nzxt 340 case
Reply




Users browsing this thread: 1 Guest(s)