Performance not up to PC's specs?
Hello, I've been trying to figure this out by myself for quite awhile now, but I'm finally giving in and asking for help. I've been trying to run several 2D sprite-based games like Ar Tonelico 2 and Summon Night 3 on my laptop, which shouldn't require a high-end machine. I am using r4600. I've tried to install the latest svn, but it kept giving me errors so I gave up. The most fps I can get up to is 45~ with speed hacks enabled. For speed hacks I tried checking all the boxes, etc. with little to no difference happening with each change. My OS is Windows 7 x64 bit.
Here are my specs:
[Image: a3mi60.png] [Image: msdp1v.png]
[Image: 2q3n5fd.png]

And my plugin settings:
[Image: zthvdx.png]
[Image: 3522a68.png]
The rest are all default settings.

I heard that Intel HD Graphics are hardly the best thing in the world, so if that's definitely the case, please inform me. I also considered overheating, but I don't think that's the case as I tried playing upon start up. I would be really grateful if someone could help me.

Sponsored links

make sure you power profile is set to High performance in control panel as I noticed that your cpu is running at only 1200 MhZ which is half of its maximum ( and in control panel>> system and security>> power options>>advanced power options make sure that min and max processor state is 100%)

Also I think that your graphics card should support dx10 so use than rather than dx9 plugin if it lets you

Also I don't know if you can manually turn on the turbo boost feature of your processor but on intel website it says your cpu can run at 2.66 GHz so that should give you a boost as long as both cores are running (you don't want to turn off the other core)

Finally give the latest beta a shot from

There is a new speedhack called mtvu in the speedhacks section of the betabuild which helps if you have more than two cores (which you don't ) but still give it a shot as some people have had a speedup with it even with two cores (turn it off if it instead slows your emu down)
Gigabyte GA-Z77M-D3H-MVP micro ATX Intel motherboard
Intel Core i5 3570K processor @3.4 GHz
Patriot G2 Series 8 GB DDR3 1600 (PC3 12800)
Sapphire Radeon HD7870XT 2GB GDDR5 RAM
Patriot Pyro SATA III 120 GB SSD
Corsair GS 600W PSU
Unfortunately, the use of MTVU will prevent the Turbo Boost. Maybe see if Hyper-threading can be disabled in your laptop's BIOS. This will allow the extra 266Mhz while using MTVU, and may very well pan out to better performance.

DEFINITELY check your "Power Plan". This could be keeping your CPU from it's potential clockrates.

I would like you to bare in mind that Intel's graphics units have been know to have troubles with utilizing DirectX10 in the past. DX10 would be a better choice, but consider reverting to DX9 if DX10 presents a problem.

And, yes, Intel's GPUs are typically weaker, and will be insufficient even at native res. It does, however, seem that the more modern HD units should be capable of light-weight 2D games (like those by Gust). What does the EE% and GS% read-outs saying?
I've changed my power setting from Power4Gear Entertainment to High Performance and made sure the processors are at 100%, but it didn't make a difference. My CPU still goes at 1000-1200 Mhz. I've tried dx9 before, and it's true that it's somewhat better than dx10 for me, but not by much. As for the turbo boost feature, you can't use it manually unfortunately. It also doesn't activate when I open PCSX2. Checking the mtvu speedhack didn't change much either.

I've tried going into my laptop's (Asus) BIOS, but I'm not sure how to disable hyperthreading. I ran PerformanceTest and it does say hyperthreading is enabled, though.

EE: 70~86% GS: 60~70%

So I'm guessing the problem isn't PCSX2 and the configuration, but that my laptop can't run at its potential speed? I tried it on my desktop which has lower specs (Intel Core 2 CPU 4300 @ 1.8 Ghz, 2MB Memory), but with a better graphics card (Geforce 7900), and the first couple minutes of Ar Tonelico 2 runs at full speed.

Thanks very much for your help, by the way.

EDIT: Okay, I figured this out and it's the most stupid mistake ever. It turns out I had this thing called Super Hybrid Engine turned on, which is basically a power saver that also lowers performance. Sorry I made you guys go through this.

Users browsing this thread: 1 Guest(s)