Persona 3 FES (Japan) says can't load disc

I bought a Japanese disc of Persona 3 FES,
I just recently moved to Japan and thought Persona could be a good game to practice Japanese since it involves real daily-life conversation.

Downloaded PCSX2 r5109 (for Mac - Lion)
Converted the DVD into an .iso file using Imgburn. (Installed Windows on my Mac as well)

The game loaded perfectly at the beginning (showing companies that did the game etc2) but straight away after that It shows this message (pic attached), The Japanese texts basically means 'I need to insert the persona 3 disc in order to play'.

So after that I tried another PCSX2 software on my Windows as well.
And it got the same result.

Could anyone help me on this?
Thanks beforehand.

I'm using :
Macbook Pro 15"
Processor : 2GHz Intel Core i7
Memory : 4 GB 1333 MHz DDR3
Graphics : AMD Radeon HD 6490M 256 MB
OS: Lion (OSX 10.7.4)

Attached Files Thumbnail(s)

Sponsored links

How are u loading the disc? Did u change anything in the emultor? Could u test the iso in other machine?
It's telling that this is the append disc, and to access the content you need to insert the original P3 game disc first. Looks like you bought the append FES disc, not the standalone FES Sad

Edit: Here's the version you want. Also in case you're wondering why it needs the original game's disc, it's only during the first startup, so it can confirm you bought the original version and aren't just buying the append FES because it's cheaper than standalone FES

Edit 2: My link isn't working for some reason... just search for ペルソナ3フェス(通常版:単独起動版)
Aha that answers everything. Thanks Synce!

Users browsing this thread: 1 Guest(s)