Persona 3 FES [NTSC-J] - minimap tiles broken
OS: Windows 7 Ultimate 64-bit
Processor: Intel Core i7 920 @ 2.67 GHz

Using 0.9.8 r4600, but the same problem existed in 0.9.7 r3878.

Emulation settings: Safest Preset.

GSdx settings: See images.

In the dungeon parts of Persona 3 FES, the minimap doesn't display properly and is nigh unreadable.

It looks slightly better in hardware mode compared to software mode.

Changing between DX9, DX10 and SDL doesn't seem to make much difference. Likewise with changing between SSE2, SSSE3 and SSE4.1.

I also tried a handful of older versions of GSdx.
The oldest one I tried, GSdx r890, was able to display the minimap perfectly in hardware mode (but using it introduced serious graphical problems elsewhere).
All of the newer versions I tried had the same problems as r4600.

Similar problem in ZeroGS r3878.

Any help getting it to work, or at least understanding why it doesn't, would be appreciated.

The images are: r4600 software; r4600 hardware; r890 hardware.


Attached Files Thumbnail(s)

Sponsored links

I think the minimap problems in GSdx appeared when the other graphic glitches in that game were fixed (mostly shadow problems), I could be wrong but... "pick your poison" sounds about right Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Could you try this again with a new GSdx set to 2x scaling?
It's a GS rounding issue, might be fine with x2..
Tried 2x scaling. No improvement.

Images are with and without texture filtering respectively.

Attached Files Thumbnail(s)
Okay, I'll see if I can find the problem Tongue2
Experimented a little with r890.

In software mode the map looks the same as in r4600.

In hardware mode it only displays the map perfectly with texture filtering off.

Image is with texture filtering on.

Attached Files Thumbnail(s)
Just a note on top of this, this isn't specific to the Japanese version, it's with all versions including FES.
[Image: 2748844.png]

Users browsing this thread: 1 Guest(s)