Petz Horsez 2 hangs on first loading screen
I've been working on getting Petz Horsez 2 working, but run into trouble after the intro video and get stuck at the first loading screen.

I followed the emulator configuration setup as described in this post but still get issues after the intro sequence

The debug window says

Set GS CRTC configuration. NTSC 640x448 @ 59.940 (59.82) Interlaced (FIELD)

I'm not sure what to do from here, I've tried setting the resolution to 640x448 but that doesn't help.

PC Specs:
Ryzen 7 3700
32gb DDR4 RAM
Geforce RTX 2080 Super
Running off a USB3.0 drive, with .iso file

I've added a link to the output log from Google Drive, it's too large to paste into this post.  Let me know if there's any more info needed to get this running in the emulator!

Sponsored links

the log says there are cheats loading. try loading the game with cheats disabled instead.
Heyo! Im currently having the similair problem that im getting stuck on a long loading screen, and then everything goes black.
I'm fairly new to this place so i do not know how to debug or what debugging is for that matter. :/.

But i tried it with cheats on and off. But neither seems to work. StealthFundip did you get it working?
This game should work fine with ee cycle rate +2 or +3
It works! for me atleast. You're amazing. Thanks alot!

Users browsing this thread: 1 Guest(s)