Physical device/renderer error?
Haven't used the emulator on this laptop for a while, decided to boot up an iso that worked previously but it fails to launch as shows these two windows? anyone got any idea what the issue might be? I changed the renderer to all those listed (software, vulkan, openGL, DX11/12 etc) to no avail. 


the specs are:
CPU: Ryzen 5800H
GC:RTX 3070 Laptop
OS: Windows 11
PCSx2 version: 1.7.4541

Using the nightly build by the way. Oh, and i also tried to fastboot the ISO and it bluescreened my laptop lol.

Sponsored links

what is your gpu drivers version ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
#3 (as listed under display adaptors in device manager)

the game-ready driver from Nvidia i have installed from the GeForce experience is 532.03

I was dreading it might be a driver issue, The only thing I can think of that's changed that would be affecting this are windows updates, driver updates, or the updates to the nightly builds, which were previously needed marginal tinkering to get working smoothly.
You might need to ddu and install both latest drivers for igpu and dgpu.
(05-30-2023, 10:35 PM)lightningterror Wrote: You might need to ddu and install both latest drivers for igpu and dgpu.

Hey, finally got around to DDU-ing the iGPU/dGPU, yep, that seemed to have fixed it. I'm wondering if always installing the new game-ready Nvidia drivers may have caused it, but i guess we'll never know. but at least it was only a display driver + chipset driver re-install was necessary, to thanks for the advice.

Users browsing this thread: 1 Guest(s)