Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Playing FMV in 4:3 with black bars
#1
Hello,

So I've been modifying some widescreen patches in order to play in 21:9. So far so great, I don't mind that much the stretched HUDs. But I don't quite like the FMVs when they're so stretched. I've noticed that there is an option under emulation settings that says "Switch to 4:3 aspect ratio when an FMV plays". But when I do this, it changes the aspect ratio but it's like it's rendering outside of my actual screen; I can't see the upper and the lower part of the video. I was wondering if there is any way to play in 4:3 but have actual black bars at both sides instead? I've been trying every option I've found and even changed in the nvidia drivers how it should scale things but nothing has worked so far. Using the latest Git version, although I've been having this problem for a while now.
Reply

Sponsored links

#2
Okay I don't know if it was very clear with just text, so I'm updating with some images.

This is how I see the image when it's stretched:


[Image: dQeGKEy.jpg]


If I change to 4:3 mode using either the setting or F6, what I get is this:


[Image: SXAzAoj.jpg]


As you can see, that's less than ideal because I'm practically missing everything on top and at the bottom. It's like it is at 4:3 but it's using the width instead of the height in order to scale. The ideal would be to have it like this:



[Image: KoYclNz.png]

I was just wondering if this is a bug / the intended way for pcsx2 to scale things or if it's something with my config.
Reply
#3
I'm bumping this because this still happens with the latest git version "v1.5.0-dev-2393-g810bec2d6". Does nobody know what could it be or how to fix it?
Reply
#4
(05-28-2018, 12:02 PM)Blareot Wrote: I'm bumping this because this still happens with the latest git version "v1.5.0-dev-2393-g810bec2d6". Does nobody know what could it be or how to fix it?

Play around with this pull request. Adjust the scaling and aspect ratio settings to see if you can get it to work. https://ci.appveyor.com/api/buildjobs/9h...ppVeyor.7z
Reply
#5
(05-28-2018, 04:59 PM)wheninrome Wrote: Play around with this pull request. Adjust the scaling and aspect ratio settings to see if you can get it to work. https://ci.appveyor.com/api/buildjobs/9h...ppVeyor.7z

Hmm, I've been trying all combinations and, well, I always have the same issue. I just noticed though that it's not an issue related to FMVs but it also happens outside of them, I just didn't check. For instance, if I put the aspect ratio to Frame or Standard (4:3), but my window size is 1280x720, everything is just cut off instead of showing black bars. Maybe that's just the intended way, but it seems weird to me.



[Image: Loe44wf.jpg]

[Image: KGVVIXV.jpg]



The odd part for me though is that when I was screenshotting with Sharex, it was telling me that the window is larger than what is showing lol


[Image: cJGefIh.jpg]
Reply
#6
FMVs look fine here using 4:3 or 16:9.

I'd say your patch is the culprit because I don't have any of the issues you're describing.

It's also weird that ShareX is doing that as well for you, because I just tested it out and it doesn't make the screenshot window larger than the PCSX2 window here.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#7
(05-28-2018, 06:57 PM)Ryudo Wrote: FMVs look fine here using 4:3 or 16:9.

I'd say your patch is the culprit because I don't have any of the issues you're describing.

It's also weird that ShareX is doing that as well for you, because I just tested it out and it doesn't make the screenshot window larger than the PCSX2 window here.

It happens with any game disabling cheats and widescreen patches, and it doesn't matter if I'm using Direct3D or OpenGL, or even software mode. I wonder what's the problem here though, the thing with Sharex IS pretty weird.

EDIT: Huh, I just extracted the latest build in a new folder, copied my bios and... well, now it doesn't do that. Maybe it's some weird leftover config from older builds? Whatever, thanks for the help guys!
Reply
#8
Quote:EDIT: Maybe it's some weird leftover config from older builds? Whatever, thanks for the help guys!

Older configs can cause issues, which is why it's recommended to use new ones for newer builds. Updating from fairly recent to latest dev for example it's ok to use older but let's say a year or more difference then no.

GSdx.ini and PCSX2_ui.ini are usually the ones that need to be reset if they cause issues.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#9
To reset inis just delete thema nd let the new PCSX2 exe recreate them
Reply




Users browsing this thread: 1 Guest(s)