"Please insert a Playstation 2 Disc" Error?
Im trying to load an ISO of Persona 4 with the emulator. Im assuming it load correctly, as the 'PS2" boots and shows the logo. But when it should load into the game, I get the error from the "PS2" that I need to insert a Playstation 2 disc.
This is not an error that the emulator is giving me, it is the emulated ps2. I dont know what I have done wrong, I have searched and could not find a solution. Any advice would help. Thank you.

If I am missing any information, please request it.

Also, this is my first time trying to load a game on the emulator, so I do not know if everything that was supposed to happen happened, or if anything went wrong, etc.

Sponsored links

Nevermind, I solved the problem.
(09-24-2012, 03:17 AM)Konaru Wrote: Nevermind, I solved the problem.

How did you solve the problem? I am having the same problem.
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
[Image: XTe1j6J.png]
Gaming Rig: Intel i7 6700k @ 4.8Ghz | GTX 1070 TI | 32GB RAM | 960GB(480GB+480GB RAID0) SSD | 2x 1TB HDD

Users browsing this thread: 1 Guest(s)