Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pretty sure PCSX2 is using integrated GPU instead of nvidia
#1
Star 
So, I play PCSX2 on an Asus Laptop running a Nvidia GeForce 920M. As the title says, I am pretty sure it is not using this card but instead the other one my laptop has, as I noticed that I have literally the same performances on battery and on elecricity.
I play some other games/emus, and all of them perform significantly better when I am plugged in. Is there any way to make sure PCSX2 is running at full hardware?
Thanks.

My specs: Intel i7 6500U, 4GB RAM, GeForce 920M GPU, W10 OS and I am using PCSX2 1.4.0 without making any modification to plugins and such
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

Also, please post your GSdx settings
Reply
#3
gsdx has a device selection dropdown menu in the options. incase your driver default is your integrated gpu you could use the nv control center's advanced program options and setup pcsx2 to explicitly use the dedicated card. or just change the device explicit in the gsdx options dialog. that's a good thing and it should work.
Reply
#4
(01-10-2018, 06:16 PM)jerry00 Wrote: So, I play PCSX2 on an Asus Laptop running a Nvidia GeForce 920M. As the title says, I am pretty sure it is not using this card but instead the other one my laptop has, as I noticed that I have literally the same performances on battery and on elecricity.
I play some other games/emus, and all of them perform significantly better when I am plugged in. Is there any way to make sure PCSX2 is running at full hardware?
Thanks.

My specs: Intel i7 6500U, 4GB RAM, GeForce 920M GPU, W10 OS and I am using PCSX2 1.4.0 without making any modification to plugins and such

As mentioned, choose the dedicated GPU from the GSDx settings to force PCSX2 into using it. You might've got it set to 'Default Hardware Device', and the default could be the integrated graphics on your laptop.
Since you're on a laptop, you could change the power plan to the performance setting in the control panel, and change the power setting to 'Prefer maximum performance' in the Nvidia Control Panel. This would make the laptop 'run at full hardware' as you asked (maybe I misinterpreted what you said Tongue)

As a last resort, you could try disabling integrated graphics from the BIOS. I would imagine that the dedicated GPU would automatically be assigned after doing this, and so any application wouldn't be able to accidentally use the integrated graphics.

As noticed, you're on PCSX2 1.4.0 so maybe it's a good idea to download the latest Git build from here: https://buildbot.orphis.net/pcsx2/
Intel i5 4460 @ 3.20 GHz,
GTX 1050 Ti,
8GB RAM,
And some other gubbins that make things work.
Reply
#5
As a side note, you should keep the adapter to "Default hardware device" in 1.5 git because PCSX2 now support the Nvidia optimus and the AMD PowerXpress wich will automaticly request the dedicated GPU.
Reply
#6
(01-10-2018, 11:58 PM)Atomic83 Wrote: As a side note, you should keep the adapter to "Default hardware device" in 1.5 git because PCSX2 now support the Nvidia optimus and the AMD PowerXpress wich will automaticly request the dedicated GPU.

Power plan at high performance would be good as well.
Reply
#7
(01-11-2018, 12:01 AM)CK1 Wrote: Power plan at high performance would be good as well.

Hello, may I know the difference between high performance power plan and the rest of power plan ? Does it only affect auto power shut down ?
CPU : I7 6700 3.4 Ghz
GPU : Gigabyte Geforce GTX 1050 TI
SPU : Realtek High Definition Audio
RAM : 16 GB
Os : Windows 10 64 Bit
Emulator : PCSX2 1.5 
Reply
#8
High performance plan ensures that programs utilize cpu and gpu at most performance possible.

Some people say balanced plan is best default because of modern systems and cpus are created to go highest on demand anyway, while saving some electricity when idle or low usage. I saw once that even some site were doing hardware reviews at balanced plan clearly stating that. BUT... we have no 100% guaranty that all internals work as it should. Cpus have its own power states, OS has its own, bios/uefi has own power modes, GPUs too and so on. Its like using laptop or PC there are many powersaving modes working at the same time, we cannot be really sure all it works nicely with each other.

Other lower plans are for laptop and saving battery only.
Reply
#9
keep it on balanced. just make sure you use the nvidia control panel or the gsdx dropdown to select the proper device.
Reply




Users browsing this thread: 1 Guest(s)