Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Primal & Silent Hill Shattered Memories still not working properly?
#1
Other titles runs flawlessly, but these are the only two games I have yet to run successfully. Primal shows a blank screen when running in hardware mode, switching to software mode makes the game run incredibly slow. While Silent hill is very buggy in hardware mode, switching to software again causes the game to run extremely slow. 

Has anyone been able to get these two games to run stably?  
I'm currently using the latest stable 1.4.0 build. 

System Specs

Intel i7 [email protected] 4.7ghz 
Gigabyte xZ170 Gaming 3 
Hyper X Fury 32GB DDR4 Ram
Nvidia GTX 970 Gaming G1 
Samsung SSD EVO 250GB  
Windows 10 64bit

These are the settings I'm using

[Image: Untitled1.jpg]
[Image: Untitled.jpg]

Sponsored links

#2
About Primal,it's not a week hardware that is making the game to run slowly...you can kinda make it work better but that's the only thing you can do for this game.
Set the EE slider to +2 and VU to 1(never above that for this game)
#3
Use the vs2013 build of PCSX2 to run software mode. Skylake has issues running current pcsx2 builds in software mode.
#4
Thank you for the the replies guys. I tried the above suggestions.

Primal still runs very slow in software mode with the vs2013 build, and slider settings. Silent hill is still very buggy and unplayable...
#5
Works great on my PS2....hahahahahaha
#6
Confirmed this.
My system is: Windows 7, Haswell processor with Intel HD Graphics 4600 + Nvidia GeForce 840M.
None of the mode - software/hardware OpenGL or DirectX is working correctly in Shattered Memories.

Hardware OpenGL mode preferrable because it give me the best graphics, but Doctor K from first opening gameplay and his speech missed completely.
In software mode Dr. K visible, however he's still silent.
#7
(02-26-2016, 08:40 PM)Dr_Hycodan Wrote: Use the vs2013 build of PCSX2 to run software mode.  Skylake has issues running current pcsx2 builds in software mode.

Latest GIT ought to fix the performance issue. So you can use VS2015. It would be nice if you can confirm it. VS2013 might be dropped soon.
#8
(02-07-2017, 04:22 PM)gregory Wrote: Latest GIT ought to fix the performance issue. So you can use VS2015. It would be nice if you can confirm it. VS2013 might be dropped soon.
You're responding to a post made almost a year ago. Wink

These games run slow even on non Skylake CPU's.
#9
No my bad ! Well it would avoid bad information to spread.
#10
Primal has a patch floating about. You'll have to find it.




Users browsing this thread: 1 Guest(s)