Primal freezes whenever it tries to start
I've tried all of the compatibility settings I can find, but the game locks up after the initial introduction movie, during the loading screen. The compatibility guide on the site says that it's 'ingame'. Is there something I'm not doing?

Sponsored links

Well, if I wait a long time, like a few minutes, I can hear background music start to play. It's still stuck at the loading screen, though.
With a "ingame" status there's not much you could try really, I think the NTSC version is only menus which looks like what you're getting currently. You could try the PCSX2 public beta and see if it goes any further, updating GSdx might help too and changing the "config > advanced" settings, but chances are you wont be able to play the game yet.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
I'm currently actually searching for this game. likely if you change your spu setting it might work (using spu2-x try zerospu2 and vise versa)
see in compatibility may not be plyable.
What about the 9.7.0 ??? I saw by now is playable on 9.7.0.Is it true ?

problem solved ... thanks Smile

pux .: R

Users browsing this thread: 1 Guest(s)