Problem Loading Game (Katamari)
Has anyone experienced issues with loading games from the memory cards?

I've just had my first PCSX2 experience [0.97.3876m]. I never owned a PS2, but since the price of used games is so low, and because my computer is close to a top end box, i thought i'd give it a go.

The first game i played was the first God of War - and everything worked perfectly. Saving and loading never had any issues.

My second game is Katamari (i also bought Final Fantasy X and GoW2, but have yet to try them). The play isn't quite perfect, but it's still good. However, i'm having issues loading saved games. It reports that it has saved fine, and i can go into the BIOS and see that there's game data. But when i go to load that saved game, Katamari tells me that there's no data on the card.

I tried creating new cards of varying sizes and swapping them into the first slot (since Katamari doesn't seem to want to see the other slots at all), but nothing seems to work. In all cases, the BIOS shows the data - but Katamari doesn't see it.

Any ideas as to what i should do? I'm not so enamored with the game that i'll want to play it all in one sitting.



Sponsored links

(10-19-2010, 04:58 AM)Justavian Wrote: ...I never owned a PS2...

Wow! So, how did you get your bios...?
Presumably you're calling me out for illegally acquiring a bios, which is, in fact, not the case. I'll also point out that while each of the games i wanted are easily accessible via torrents online, i chose to buy the games i wanted - for the same reason that i've donated $40 to the PCSX2 cause - i have money to spend, and i want to reward the people making products i like.

In any case, my original problem with the memory card seems to have disappeared. For whatever reason, the first save point was the only problem. No matter how many times i switched memory cards, restarted the game and played the first level, i could not get it to register that save point. After i completed another level or two, however, it seems to have fixed itself. I can save now - though i can still repeat the original issue by restarting the game and trying to play just the first level.
If you don't have a PS2 you don't have a limited usage licence for the BIOS. It doesn't matter if you downloaded it or dumped it on a friend's console, you can't legally use it without owning a PS2.
Specs in Profile

Users browsing this thread: 1 Guest(s)