Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem With FPS Limit
#1
Good night to every one.

I have recently buy a new PC:
AMD FX-4300 4Cores
8GB RAM
ATI HD 7770 1GB DDR5

And I have a problema with FPS Limit with the game Dark Cloud (I don't have cheked more games yet).

If a don't put on the FPS limit the game Run at 80 FPS all time, but if I active the FPS limit the game FPS are between 40 and 70 FPS, causing jumps in the game.

Are there any solution to this?

Sorry but my english but I don't write in English for many years¡¡
Reply

Sponsored links

#2
Pressing f4 may solve!
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#3
Games need to run at 60fps to run correctly fps past, 60 make the game and sound run to fast, FPS below 60 make the games runs to slow and sound slow.

Choices are run with the framelimit and deal with the drops or run with it off and break things. Food for thought though AMD's are terrible for emulations with pcsx2 most them need very high OC;s just to compete with Intel base clocks.

You could try puting on MTVU hack it might help but it might break things as some game dont like MTVU on amds
Reply
#4
(11-05-2013, 09:37 PM)tsunami2311 Wrote: Food for thought though AMD's are terrible for emulations with pcsx2 most them need very high OC;s just to compete with Intel base clocks.

I disagree. I have no problem with mine. My base clock is 3.5 ghz and turbo is 4.1 ghz. I turned off turbo and just set full time 4.12ghz. I wouldn't call that a very high OC(I can hit 4.5ghz but heat is a big problem). And yeah, at that speed my AMD FX 6300 does just fine.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#5
(11-05-2013, 11:57 PM)Blyss Sarania Wrote: I disagree. I have no problem with mine. My base clock is 3.5 ghz and turbo is 4.1 ghz. I turned off turbo and just set full time 4.12ghz. I wouldn't call that a very high OC(I can hit 4.5ghz but heat is a big problem). And yeah, at that speed my AMD FX 6300 does just fine.

That is very subjective, he says nothing about OC on his cpu, and at base clocks AMD perform way worse then intel at base clocks, this all subjective to what he playing too, And if i remember correctly dark cloud is cpu demanding, I could be wrong though
Reply
#6
(11-06-2013, 12:23 AM)tsunami2311 Wrote: That is very subjective, he says nothing about OC on his cpu, and at base clocks AMD perform way worse then intel at base clocks, this all subjective to what he playing too, And if i remember correctly dark cloud is cpu demanding, I could be wrong though

I'm not arguing that intel has better per clock performance, just the overt generalization "AMD's are terrible for emulations with pcsx2" is all. It makes it sound like they are useless. It's more like "Intel processor work better with PCSX2 than AMD ones" That's all I was getting at.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#7
I think that no one understand my problem.

If I active FPS limit by pressing F4 the FPS are jumping between 40 and 70 FPS all the time, in this case the problem is that the game speed is variable and is horrible to play.

If I turn off FPS limit, the FPS is 80 all the time but the game Run to fast¡¡


Can I activate the FPS limit and make the FPS stable at 60FPS all the time?
Reply
#8
(11-06-2013, 12:49 AM)ildelian Wrote: I think that no one understand my problem.

If I active FPS limit by pressing F4 the FPS are jumping between 40 and 70 FPS all the time, in this case the problem is that the game speed is variable and is horrible to play.

If I turn off FPS limit, the FPS is 80 all the time but the game Run to fast¡¡


Can I activate the FPS limit and make the FPS stable at 60FPS all the time?

I understand perfectly what you are saying, I just have no idea why it would do that. All I can say is make sure VSYNC is off.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#9
If it cant keep it at 60 fps sync it will go lower, its just how it is.

Short of making sure the AMD card is not throttle cause of some adaptive power setting, and check with mtvu hack on and off, it cant be help less you start OCing, and if the orginal game had fps dips then the emulation will have them too
Reply
#10
But, If I use no frame limit the FPS is constant.

For example, Naruto Ultimate Ninja 5:

FPS LIMIT ON: 40-55 FPS Variable
FPS LIMINT OF: 139 FPS Constant

I don't understand why
Reply




Users browsing this thread: 1 Guest(s)