Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem configuring Gigaherz Dev9 on PCSX2
#1
Hello,

I apologize if I am posting this in the wrong subforum as I am new here (and also new to the PCSX2 emulator in general.) I am aware that there have been several threads/posts submitted to this forum (and several other forums I was able to find using Google search) regarding this issue, however I have yet to find a working solution for the problem.

I am trying to set up PCSX2 for online play. I'm aware that the Gamespy servers were shut down and most of the PS2 game servers are no longer accessible, but I would like to try anyway (perhaps I can find a workaround by configuring my HOSTS file to trick PCSX2 into connecting to a different server instead of gamespy, etc)

I followed the directions in your official "How to play online" guide (http://forums.pcsx2.net/Thread-How-To-Play-Online-Guide) to the letter, but I am still unable to get this to work properly.

Here is what I've done so far, please let me know if you see any errors in the steps I've taken:

* Downloaded and installed WINPCAP
* Restarted my computer
* Downloaded Dev9gigarazi from the link in the "How to play online guide (http://pcsx2.net/download/viewcategory/9-plugins.html)
* Copied the Dev9gigarazi DLL file into my PCSX2 plugins directory
* Downloaded the Disc ID Util CD Version ISO file from the link provided it the "How to play online" guide (http://forums.pcsx2.net/attachment.php?aid=13201)
* Started up PCSX2 and booted up the Disc ID Util CD ISO
* Selected the ISO file for the game I want to play online, clicked "Swap disc" and wrote down the IDs that were displayed on screen
* Downloaded and ran WINDIP, patching my game's ISO file according to the instructions provided in the "How to play online" guide
* Attempted to repeat steps 4-6 from the "How to play online" guide with the Online game disc iso file, but was unable to use the Online game disc because it reported that there is no network adapter installed. I assumed this was because I had not yet selected the Dev9gigarazi plugin.
* Clicked "Shut down" in PCSX2, went to Config -> Plugin/BIOS Selector -> Plugins and selected "GiGaHeRz's DEV9 Driver 0.3.0 [DEV9ghzdrk]"
* Clicked "OK"

At this point, PCSX2 crashed, I got a Windows error dialog box saying the application stopped working. I did some Googling and found a post saying that this is apparently caused by the Dev9 driver not being configured. So I opened up PCSX2 again, went to the plugins setup menu, selected the Gigaherz dev9 plugin again and this time, I tried to click on "Configure" before clicking "OK". However, the "configure" button is greyed out - it doesn't allow me to click on it. Here are some screenshots illustrating the problem:

Figure 1 - Trying to select the Gigaherz Dev9 plugin in PCSX2. Notice that "configure" is greyed out and unclickable.

[Image: 30beot1.jpg]

Figure 2 - Error message after selecting the Gigaherz dev9 plugin, clicking "OK" and having PCSX2 crash
[Image: 20ponx3.jpg]

Here are my system specs:

CPU: Intel® Core™ i7-4930K CPU @ 3.40GHz, 3401 Mhz, 6 Core(s), 12 Logical Processor(s)
GPU: Nvidia GeForce GTX-780
RAM: 16GB DDR3 SDRAM
OS: Microsoft Windows 8.1 (Version 6.3.9600 Build 9600)

I tried launching PCSX2 as Administrator, but this did not help. I also did install the Microsoft Visual C++ 2013 Redistributable (x86) package prior to installing PCSX2 (and I did reboot my system afterwards.)

Please let me know if there is any way to resolve this problem or if you need any more information.

Thanks!

P.S. I just want to say thank you to all the folks who helped develop this emulator. Truly awesome job guys, I'm very impressed.
Reply

Sponsored links

#2
Ok well just an update, I wanted to let you guys know that I figured out how to get the Gigaherz Dev9 plugin to work. Apparently the installer version of PCSX2 doesn't like the plugin. I had to download the binary version. I copied over all the directories containing my configuration settings, memory cards, etc into the binary's working directory so I wouldn't lose all my settings and savegames. This allows me to load the Gigaherz dev9 plugin and I was able to successfully configure it using the network disk. However I'm getting a DNAS error now when I try to get online in my game, so I'm going to have to research that one and figure out a solution to that.
Reply
#3
Are you sure your game still has active servers?
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#4
There is a lot of unofficial servers out there, if you can modify the addresses it goes to, you can do it.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
Ok another update, guys. I managed to resolve the DNAS error I was getting. I was getting DNAS error -864. Apparently the disc ID that the Disc ID tool was pulling up for my game was completely incorrect. I found the correct ID from another forum, but I'm not sure if I should be posting a link to it here due to potential legal issues (I don't know, I'm not a lawyer). I repatched my game's ISO file with the correct ID and networking works now! Unfortunately, there is apparently NO GAMES to join, although the server browser does appear to be working and it authenticated my gamespy account successfully (which is weird, I thought gamespy was down?) Who knows, maybe if I start one up someone will join me.

The game I'm trying to play online is Midnight Club 3: Dub Edition Remix. This game was awesome when it first came out and looking back at it now in 2014, it really hasn't aged too badly. It's still very playable and the graphics are pretty nice!
Reply
#6
You do know that Gamespy servers are totally offline now right? And it's permanent
Reply
#7
Maybe there really isn't any games on there already going? I highly doubt it's very popular any more Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#8
(07-16-2014, 12:04 PM)StriFe79 Wrote: You do know that Gamespy servers are totally offline now right? And it's permanent

Yes, I am aware of the gamespy shutdown. Curiously, however, the game is able to authenticate my gamespy account. My friends list is still on there, etc. I just thought that was kind of weird.

And yes, Refraction, you are probably right about that. Perhaps its time for a revival!
Reply




Users browsing this thread: 2 Guest(s)