Thread Rating:
  • 1 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems playing Persona 3&4
Ok, I recently started playing Persona 3 using PCSX2. I configured using guides from the forum. Everything was going quite while until I went to Iwatodai Station. Whenever I entered the station from the map, the loading stops and the emulator becomes not responding, leaving me no choice but to close it. Soon I gave up and move on to play Persona 4. This one's even worse, I typed in my name and left the Velvet room. The intro movie of the main character starts and ends. The moment it ended the emulator goes not responding again. Is there anyone who can solve this?

I'm using a Dell Studio 15, the specs are:
Intel Core 2 Duo CPU @ 2.20ghz each
3gb RAM
Windows 7 32-bit
ATI Radeon HD 4500/5100 Series
(Btw I use Speedhacks, the result is the same even if I don't use)

Sponsored links

Change the VU0 and VU1 to superVU recompiler [legacy]. And tick Enable Automatic Gamefixes under PCSX2 --> System.

Hope it works fine. Smile

Also, download the latest PCSX2 SVN
[Image: recodersignature2.png]
Thx man. Problem solved for Persona 4 for now. Haven't try Persona 3 yet. Should be fine.
Glad it solved the problem Smile. Maybe it will work for Persona 3 too.
[Image: recodersignature2.png]
Now it got a bit glitchy and slow for Persona 3. Should I use Speedhack?
If its slow then use Speedhacks. The above problem was not for Speedhacks. It just needed a gamefix which works in SuperVU recompiler. Smile
[Image: recodersignature2.png]
Ok, thx again.
Welcome. Smile. Though its a VU Glitch try use the GSDX Software mode.
[Image: recodersignature2.png]

Users browsing this thread: 1 Guest(s)