Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Proper resolution setup
#1
Hello, everybody, this is my first post here, and one of the few in my life...

I'm using the latest 1.4.0 PCSX2. My monitor (benq gl2070) has a native resolution 1600*900

with 16:9 aspect ratio. I want to play Silent Hill Origins, the game supports aspect ratios 4:3 & 16:9.

I want to play this game like on console, without modes, which the console is not capable of.

I can choose between 2 modes - hardware or software, when i choose one, all that remains

is to set the correct values in GS Window (Config/Video(GS)/Window Settings...).

When i go to Config/Video(GS)/Window Settings... there are:

- Aspect Ratio with 3 options - Fit to Window/Screen
                                           Standart (4:3)
                                          Widescreen (16:9)
 
- Custom Window Size - with possibility to set the resolution.

Next point is, when i go to bios/system configuration/screen size there are 3 options:

- 4:3
- full
- 16:9

My settings are:
01. Bios/System Configuration/Screen Size - Full
02. Config/Video (GS)/Window Settings/Fit to Window/Screen, in Custom Window Size i enter
1600*900 & save. When i reopen this settings later again those are 1584*852. And i don't
know where those pixels disappear.

All i need is adjust the original image of the game to the monitor resolution correctly.

I don't need any widescreen fixes, in this case i would rather use the aspect ratio 4:3.

What should i do in case i want to play the game with 4:3 (calculations are welcome)?
What should i do in case i want to play the game with 16:9 (calculations are welcome)?

Please help me with a proper resolution setup... Where should i start?
Reply

Sponsored links

#2
use x3 native resolution (in hardware mode, of course) + stretch screen in aspect ration. IIRC, what you set in PS2 bios won't affect emulation.
setting a custom resolution is a bad idea and will produce glitches.

using a "native multiplicator" will give you what you're looking for
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Edit for clarity: I think what jesalvein is referencing is the upscaling system in GSdx; if I am understanding right, you are not worried about that, but the plain old Window Size settings in the main PCSX2 settings.

When it comes to the Window Size settings, keep in mind those dimensions are of the space that the game itself renders in, without accounting for the window frame or any other objects on screen. Meaning, if you set that to 1600x900, you are telling it to make the inner contents of the window frame the size of your entire screen. Then the window frame wraps around that, exceeding 1600x900, then you are trying to squeeze this into a space smaller than 1600x900 (because of the Windows task bar).

Those smaller dimensions are there because when you maximize (hit the button that makes the window automatically fill out the empty space of your screen), it adjusts the rendering space to those dimensions. In other words, those are the correct dimensions if you want the window to properly fit your monitor.

If this still bugs you, then consider playing in full screen mode instead, which will use the entire screen space.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#4
(01-25-2019, 10:12 PM)pandubz Wrote: Edit for clarity: I think what jesalvein is referencing is the upscaling system in GSdx; if I am understanding right, you are not worried about that, but the plain old Window Size settings in the main PCSX2 settings.

When it comes to the Window Size settings, keep in mind those dimensions are of the space that the game itself renders in, without accounting for the window frame or any other objects on screen. Meaning, if you set that to 1600x900, you are telling it to make the inner contents of the window frame the size of your entire screen. Then the window frame wraps around that, exceeding 1600x900, then you are trying to squeeze this into a space smaller than 1600x900 (because of the Windows task bar).

Those smaller dimensions are there because when you maximize (hit the button that makes the window automatically fill out the empty space of your screen), it adjusts the rendering space to those dimensions. In other words, those are the correct dimensions if you want the window to properly fit your monitor.

If this still bugs you, then consider playing in full screen mode instead, which will use the entire screen space.

Thank you for answers, guys, ok, i have a monitor with 1600*900 resolution and 16/9 ratio, i can play in software or hardware mode, what should i do to play the game on my monitor - what should i set?
Reply




Users browsing this thread: 1 Guest(s)