Pushed: [Bug Report] Driv3r [NTSC/PAL]
So recently, I decided to try Driv3r on PCSX2. I boot up PCSX2 1.4.0 to find the horrors that are the graphical bugs.

Driver 3, or Driv3r, is unplayable in Hardware mode on both OpenGL and D3D11. Distorted visuals everywhere makes the game nightmarish to play, however software mode whilst slow is playable.

PCSX2 Version: 1.4.0
CPU: Intel Core i5-4690 (3.5GHz)
GPU: GTX 960 2GB

I tried with the latest git version of 1.5.0 and this fixed the background buildings having warped textures, however the game remains unplayable. I've tried hardware hacks and safer presets but to no avail. Here's some of what I'm experiencing.

[Image: 02fS4tw.png]

This is Driv3r on HW mode on a good day. Once you start moving the bugs get much worse, with textures like on the car occupying the rest of the place, like on the roads and paths.

[Image: ADfkAC4.png]

This is the startup screen (things like memory card formatting, name entry etc). Text is illegible without SW mode, text is legible at native on HW mode however. I'm playing that at a resolution of 1920x1080, approx. 3x native.

Now, compare that to software mode and it's a far better result, albeit at native.

[Image: 09yrUAq.jpg]

The car's colour on software mode can change for no apparent reason, but other than that the game's basically perfect.

Help would be appreciated - I've even tried ultra blending accuracy on OGL to no avail along with countless other options I've messed with.

Edit: Unless somebody says SW mode is the only option, I'd rather not play at native resolution with semi-minor slowdown

Sponsored links

SW mode is the only option as this is a mipmapping issue and only SW mode supports it.
[Image: XTe1j6J.png]
Gaming Rig: Intel i7 6700k @ 4.8Ghz | GTX 1070 TI | 32GB RAM | 960GB(480GB+480GB RAID0) SSD | 2x 1TB HDD
(04-16-2016, 08:36 PM)Blyss Sarania Wrote: SW mode is the only option as this is a mipmapping issue and only SW mode supports it.
Mipmapping is just a small part of the issues of this game(and Parallel Lines, same engine).

There's already a git issue open about this game's problems: https://github.com/PCSX2/pcsx2/issues/923
Thank you for your report.
This bug report has now been marked as Pushed and has been posted as an issue in our Github repository HERE

Issue link:

This thread will now be moved in the Pushed bug reports subforum.

Users browsing this thread: 1 Guest(s)