Thread Rating:
  • 5 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Qemu USB Wheel/Storage mod (Singstar test)
Oh well, probably I missed that. Thank you!
Reply

Sponsored links

(08-12-2018, 10:52 AM)jackun Wrote: Did you download and use the formatted FAT32 image and unpacked it?

The mass-storage fails if it cannot load its setting, then it should print "usb-msd: Could not load settings" to console or if it cannot open image file. Click Misc > Show console from PCSX2 menu.

Hello sir, first of all thank you for making the plugin, playing racing games on PCSX2 would never be such immersive experience without your effort!

However, I've used the image you provided, hooked it up to the emulator, pictures from GT4 was successfully transferred to the image file, but how do I get those pictures out from it? Tried to mount it with Daemon Tools but it said the image was locked.

***EDIT***

Nevermind!! I tried to use 7zip to open the image file after shutting down the emulator, now I can admire my photos!!  Biggrin Biggrin

   
   

***EDIT2***

Now here comes another problem... Tourist Trophy doesn't seem to recognize my wheel, used the same setting as I play GT4 and wheel settings doesn't even show up in Options menu. Will try playing around with settings and see if there's any other way to make it work.
Reply
Hi there!
I'm trying to get my G25 to work with this and GT4.

I've got it working in DInput mode, but apparently, I should be using raw input? Is there a difference? Force feedback feels a bit weird, and I'm not sure if that's an issue with using DInput or something about my wheel (it is ancient). 

I can't get raw input to work properly. The controls are all messed up, even if I define them in the configuration app, nothing seems to be assigned correctly.
Reply
(08-28-2018, 06:53 PM)JoSpanner Wrote: Hi there!
I'm trying to get my G25 to work with this and GT4.

I've got it working in DInput mode, but apparently, I should be using raw input? Is there a difference? Force feedback feels a bit weird, and I'm not sure if that's an issue with using DInput or something about my wheel (it is ancient). 

I can't get raw input to work properly. The controls are all messed up, even if I define them in the configuration app, nothing seems to be assigned correctly.

HI, have you solved your problem? I have exactly the same problem. Mine is logitech G29 steering wheel.
      If I select Dinput mode, the FFB seems not proper, a little out of control. But the raw input mode, some buttons cannot be bound, like the hatswitch buttons, up down ,left and right, and In game, the buttons are messed up.
     Could the author or anyone else help me?
Reply
I've got a new PC. Installed PCSX2 and usb emu plugin.
When trying to use my G27 I find out that raw mode does not work.
Wheel axis is mapped to throttle axis (while in game). Buttons don't work.

In plugin config cant map the "face" buttons (cross, triangle...)
Even if I map correctly the axis in the config, in game it does not work.
What I'm doing wrong?

Raw input works if the logitech driver/software is installed?
Reply
Hi there,
I got the plugin working for singsar on windows and linux but I have problems with audiodelay from the mics. How much delay is normal in singstar? Has anyone also had problems like this? I even tried on different computers. The game runs steady at 100% speed.
Thanks for the great plugin and your support Wink
Reply
(03-01-2019, 02:52 PM)weaster007 Wrote: Hi there,
I got the plugin working for singsar on windows and linux but I have problems with audiodelay from the mics. How much delay is normal in singstar? Has anyone also had problems like this? I even tried on different computers. The game runs steady at 100% speed.
Thanks for the great plugin and your support Wink

Could someone please explain how to install this plugin on ubuntu 18.4? I read the readme file and it said I need to create a virtual machine, which seems a little overkill. I really just want it to play my old singstar games with the kids, I still have the original mics. PCSX2 runs fine, but I doesn't recognize the mics.
Reply
(04-06-2019, 09:20 PM)bsteel Wrote: Could someone please explain how to install this plugin on ubuntu 18.4? I read the readme file and it said I need to create a virtual machine, which seems a little overkill. I really just want it to play my old singstar games with the kids, I still have the original mics. PCSX2 runs fine, but I doesn't recognize the mics.

You just need to download the .deb from the github releases page: https://github.com/jackun/USBqemu-wheel/releases and install it.
It will then copy the plugin in your pcsx2 folder. Then you can select it in USB-plugin options and choose your singstar mics as input devices.
I also struggled to find that  Biggrin
Reply
(04-06-2019, 10:47 PM)weaster007 Wrote: You just need to download the .deb from the github releases page: https://github.com/jackun/USBqemu-wheel/releases and install it.
It will then copy the plugin in your pcsx2 folder. Then you can select it in USB-plugin options and choose your singstar mics as input devices.
I also struggled to find that  Biggrin

Hey thanks man. This is what I was missing, After I installed it, I had to copy libUSBqemu-wheel.so into my actual PCSX2 plugin directory, but it works! Also, not sure if you still have that problem but I fixed the latency issue by lowering the PCSX2 audio plugin latency.
Reply
Hi,

I've been trying the singstar functionality with non-singstar mics and noticed that you can not use 2 different mics.

Here are my plugin settings:

Device type:
port1: Singstar
port2: none

Device API:
port1: WASAPI
port2:

WASAPI settings:
Player 1: USB mic
Player 2: normal mic
-> results in Player one can sing through USB mic normally. Player 2's input is dead.

tried some different configurations:
Player 1: normal mic
Player 2: USB mic
-> results in Player one can sing through normal mic normally. Player 2's input is dead.

Player 1: any mic
Player 2: any mic (same one)
-> any mic registers for both voice lines (as expected for a stereo mic)

Player 1: none
Player 2: any mic
-> any mic registers for player 2

tried versions 0.4.x to 0.7.4 with the same results

Is this a bug?
Reply




Users browsing this thread: 1 Guest(s)