Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Question about Video settings
#1
Hey all, I was just looking to get some general troubleshooting here. 

I recently installed the latest PCSX2 1.5.0 build from the Orphis list of automated builds, and
everything was working fine until I went to configure my video settings, and I noticed that the option
to select my graphics card under the adapter tab was grayed out, like here: https://i.imgur.com/pYKeW0K.jpg

I was just wondering if there was any way to get it to show up because I'm not sure if it will have any
effect on my games performance.

I am using a fairly new ROG Gaming Laptop if that helps
Specs: 
Nvidia GeForce GTX 1050
Intel® Core™ i7-7700HQ CPU @ 2.80GHz (8 CPUs), ~2.8GHz
16 GB Installed RAM
Windows 10

Thanks  Biggrin
Reply

Sponsored links

#2
For OpenGL,pcsx2 is automatically using nvidia without asking which is also recommended for a pc\laptop with nvidia card
If you switch to DX the menu will become active

If you are in doubt if pcsx2 is using your nvidia gpu,when you run any game,you will see the gpu used in the log
Code:
Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
Opening USB
Opening FW
Opening DEV9
3.x GL context successfully created
OpenGL information. GPU: GeForce GTX 1060/PCIe/SSE2. Vendor: NVIDIA Corporation. Driver: NVIDIA 430.39
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_viewport_array is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available
INFO: GL_ARB_get_texture_sub_image is available

Current Renderer: OpenGL (Hardware renderer)
Available VRAM/RAM:3840MB for textures
Reply
#3
Yep. This change was added somewhere along the 1.5 builds. All along OpenGL has never allowed you to explicitly set a device. It's just a part of the framework, it always asks the OS what device to use (hence the importance of Nvidia control panel profiles and the "Run with Graphics Processor" right click option in Windows).
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#4
OGL also available on ATi "but" usage is very high than nvidia....as i checked on the task manager's GPU usage meter.

oh BTW we also have the ROG laptop because it has a cooling pipeline on it we picked i5 instead of i7 to avoid hyperthreading and unexpected heat issues

the GTX is the same as yours,16gb ram same as yours,but we added M.2 ssd for windows booting speed,windows updates,RPCS3 and Nox emulator...i didnt post it on my siggy...desktop still my priority.

if you already bought the i7 thing it will alright...since as i said ROG has a unique cooling pipeline.
MAIN RIG:i5-7600(3.5ghz)GTX 1660Ti 6GB/192bit/gddr6/OC/WF,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,2pcs.Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply




Users browsing this thread: 1 Guest(s)