Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Question about fluid gameplay
#1
Hello again, i have a question about fluidity of gameplay on pcsx2.
I have noticed that every game I'm playing is showing me constant 60 fps while game seems to have very SLIGHT fps drops from time to time, no matter how scaling I set. It is just like typical fps drop in console gaming - no sound distortion at all, even not showing fps drop below 59fps in pcsx2, just a little cranky animation at times.

How this could be eliminated?
Reply

Sponsored links

#2
Possibly with EE/GS overclock, but from my own experiments, that doesn't really help.

The games drop FPS on real PS2 and hence they do on PCSX2 too.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
Well You are right for the most part,but I remember Castlevania Lament Of Innocence to be solid and constant fluid on ps2 and it gets a bit choppy in pcsx2 v1.2.1.
Again - it looks like some slight drop in fps, like from 60 to 55 or 50 but pcsx2 shows constant 60, no sound distortion at all, EE going usually 50-70% (rarely above) and GS about 20% while scaling set to 3x.

Maybe some tweaks in core options could improve this? Never really touched anything except setting zoom to 101%.
Reply
#4
What are your settings and specs?
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#5
SPECS:
Pentium g3420 3.2ghz
Geforce gtx750 1gb gddr5
4gb ram ddr3 1600mhz
Reply
#6
(12-11-2014, 12:24 AM)belmont1990 Wrote: Well You are right for the most part,but I remember Castlevania Lament Of Innocence to be solid and constant fluid on ps2 and it gets a bit choppy in pcsx2 v1.2.1.
if you want a fluid gameplay use software mode (or) disable all the speedhacks and use hardware mode
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#7
Tried disabling speedhacks and playing in hardware mode - no difference at all in my opinion.
I mostly play Dragon Quest VIII and some Castlevania LoS, I remember especially well the second one on actual PS2 - have beaten several times, animation was constantly fluid with no drops at all, in PCSX2 there are some choppy animation for about 1-2 sec. every now and then BUT program shows me constant 59-60 fps, like I said before no sound distortion at all (and I have enabled none synchronising mode in SPU)What other settings could be related to this?
My settings in core are standard, with 16:9 and 101% zoom, the plugins are    

Also I use fast boot everytime if that means anything, PCSX2 v1.2.1, GSdx 0.1.16 SSE41.

BTW about SPU plugin - I now use 4-catmull ROM which is labeled as SLOW, how heavy it is on CPU? Is it better to use 1-Linear (OKAY SOUND) to get better performance overall and not lose quality of sound?
Reply
#8
There was one member who said that linear interpolation is actually the best.. since ears in opposition to eyes love linear interpolation...
So setting to linear might not be the worst idea.

If fps seem to be lower than displayed it could be that you are using too many speedhacks...


When you see slowdowns does this happen when a lot of new stuff is loaded? (new level, new move, new enemies... something like this?)
Reply
#9
I only use recommended speedhacks that were ON from the start.

The slight slowdowns occur rather randomily for example I can run in circles in some small room in castlevania and about few seconds (10-15) there will be slight choppy animation for about 1-2 sec. - never had this on actual PS2.

Another important thing is when I turn off frame limiter I get 90 to 130+ fps depending of stage, so PC can handle 60fps alright, don't have a clue from where this choppy fragments come from...
Maybe I can somehow set it to constant 60.00 fps in NTSC mode? Saw this option in core settings at 59.90 but was grey and I could not change vales at all.

I have the latest nvidia drivers and updated directx.
Reply
#10
Can you disable the power saving option in the Nvidia Control Panel? I'm not using an Nvidia card, so I don't know the details.
Reply




Users browsing this thread: 1 Guest(s)