Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RTX 3080 / RYZEN 7 5800X LAG PLZ HELP
#1
Hi guys,

Can anybody tell me why PCSX2 is lagging for me when it shouldn't be? I've tried old buils, dev builds and nothing is working my games are still lagging when they are playable as I played them on my last pc which had a GTX 1070/i5 7600. I've used GL hardware and D311 hardware and even tried using the softwares on the original and base P2 resolution and nothing is working? I've used the exact same settings as other people for instance, to play GTA Liberty City Stories, and it still lags despite me having a high end pc. 

Any suggestions? 
BTW I've been trying to play in 1440p & 16x anistropic filtering.
Reply

Sponsored links

#2
Can you show your GSDX settings please
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
(09-13-2021, 09:46 PM)refraction Wrote: Can you show your GSDX settings please

Here are all of my settings
[Image: jRYQwFg.png][Image: hqrkLrs.png][Image: PFeZ6Xj.png][Image: f2bKKeU.png][Image: qpucb4V.png][Image: P2TnGre.png][Image: kuEg65x.png]
Reply
#4
tried lowering internal res ? OGL is better for nvidia cards
and setting crc hack level to default ?

edit : and using 16x aniso may hammer your gpu too
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(09-13-2021, 10:01 PM)jesalvein Wrote: tried lowering internal res ? OGL is better for nvidia cards
and setting crc hack level to default ?

edit : and using 16x aniso may hammer your gpu too

I'll see now, but my CPU should hve no problem running it since my last PC's processor was terrible and it could handle games on 4k monitor... not sure what I've done here but it's hella annoying
Reply
#6
I'd say it's more a gpu issue
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
(09-13-2021, 10:04 PM)Liam. Wrote: I'll see now, but my CPU should hve no problem running it since my last PC's processor was terrible and it could handle games on 4k monitor... not sure what I've done here but it's hella annoying

Strange, games are literally unplayable. I had an RTX 2070super a few weeks ago which I sold buit before selling PCSX2 was working fine. I then upgraded to what I have now, and now it doesn't work
Reply
#8
exact same settings as before ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
Tick "Allow 8bit textures" that should give you a performance increase. however if your PC is running worse than your old one, you might consider looking in to that, it's unlikely the emulator will have caused that issue.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
(09-13-2021, 10:14 PM)jesalvein Wrote: exact same settings as before ?

I do no recall changing anything at all. I've literally copied someones video from youtube with their settings with the same game and my pc is more powerful and it's lagging
I also made this video, video didn't pick up my frame rate but it's around 30-45 


(09-13-2021, 10:14 PM)jesalvein Wrote: exact same settings as before ?

Every other PC game I've played I've had an increase in performance across the board. It's only this where I'm now having problems...

Every other PC game I've played I've had an increase in performance across the board. It's only this where I'm now having problems...
Reply




Users browsing this thread: 1 Guest(s)