Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ran git pull --recuse-submodules, can no longer build [SOLVED]
#1
Hello all,

I was able to build PCSX2 fine on Friday (October 2nd 2020) but after running git pull --recurse-submodules from the repo I get an error while building (note: it may not be the --recurse-submodules that is the problem, but it's the only thing I have done differently since the last build).

This is what worked before:
Code:
mkdir build && cd build
cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/home/*MYUSERNAME*/usr" -DPACKAGE_MODE=True
make -j8
make install
Now I get a bunch of errors around 75%. There are too many to see in the bash window so I have summarized them below
Code:
In file included from /home/*MYUSERNAME*/pcsx2/pcsx2/gui/AppConfig.h:20,
                from /home/*MYUSERNAME*/pcsx2/pcsx2/SPU2/Linux/CfgHelpers.cpp:16:
/home/*MYUSERNAME*/pcsx2/pcsx2/./CDVD/CDVDaccess.h:102:23: error: ‘_CDVDgetTrayStatus’ was not declared in this scope
typedef s32(CALLBACK* _CDVDgetTrayStatus)();
                      ^~~~~~~~~~~~~~~~~~
/home/*MYUSERNAME*/pcsx2/pcsx2/./CDVD/CDVDaccess.h:103:13: error: ISO C++ forbids declaration of ‘s32’ with no type [-fpermissive]
typedef s32(CALLBACK* _CDVDctrlTrayOpen)();
            ^~~~~~~~
/home/*MYUSERNAME*/pcsx2/pcsx2/./CDVD/CDVDaccess.h:103:13: error: typedef ‘s32’ is initialized (use decltype instead)
/home/*MYUSERNAME*/pcsx2/pcsx2/./CDVD/CDVDaccess.h:103:13: error: ‘CALLBACK’ was not declared in this scope
/home/*MYUSERNAME*/pcsx2/pcsx2/./CDVD/CDVDaccess.h:103:13: note: the macro ‘CALLBACK’ had not yet been defined

In file included from /home/*MYUSERNAME*/pcsx2/pcsx2/SPU2/Linux/CfgHelpers.cpp:16:
/home/sdebian/pcsx2/pcsx2/gui/AppConfig.h:46:9: error: ‘wxDirName’ does not name a type; did you mean ‘wxGuardName’?
  extern wxDirName GetUserLocalDataDir();
        ^~~~~~~~~
        wxGuardName

/home/*MYUSERNAME*/pcsx2/pcsx2/./Config.h:208:11: error: ‘OpEqu’ was not declared in this scope
    return OpEqu( bitset );
          ^~~~~
There are many more, but they seem to be variations on the ones listed. I have attached a the full output.

Things I have tried:
  • Periodically pulling from the repo
  • Deleting the project folder and cloning from scratch (with and without --recurse-submodules)
  • Pulling a commit from before Friday
I don't know what I have done wrong. Any ideas?

My spec:
OS: Debian 10.6 Buster
CPU: AMD FX-8350
GPU: NVidia GTX 1050Ti
RAM: 8GB DDR3


Attached Files
.txt   error.txt (Size: 142,16 KB / Downloads: 10)
Reply

Sponsored links

#2
It's not your fault.

There's currently an issue on CMAKE < 3.16 because of lack of PCH. We missed a few PCH includes in the spu merge.
We fixed one of them on master but a few still remain.


We're working on getting this integrated our CI so we can fix it and avoid this problem in the future.
[Image: HkgHT5k.gif]
もっとちゃんと言ってよ
忘れないようメモにしてよ



Reply
#3
Ok, thank you. Marking as solved.

Edit: for anyone else using Debian, there is a newer version of CMake in buster-backports that allows PCSX2 to build without issue.
Reply
#4
Hello, just an update

Should be sorted on master now if you wanna give it a go.
[Image: HkgHT5k.gif]
もっとちゃんと言ってよ
忘れないようメモにしてよ



Reply
#5
Oops. By the time I saw your reply I had already upgraded to the backported version of CMake, so I can't test on the old version. Sorry.
Reply
#6
No worries, was just letting you know in case you were waiting on us.
Sorry for the trouble.
[Image: HkgHT5k.gif]
もっとちゃんと言ってよ
忘れないようメモにしてよ



Reply




Users browsing this thread: 1 Guest(s)