Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Random lag with every game
#1
Hi all, this is my first post in the forum and I was wondering if someone could help me with a problem. I am using  PCSX2 1.4.0, and I am having a weird lag problem with it. I have configured the emulator so everything runs and looks great, but every 30 seconds or seconds or so I get kind of a a lag spike. The weird thing is I get no frame drops at all. Its just strange because it runs perfectly but every 30 seconds it just hits that lag for a few seconds. 

I am not sure what pertinent information to post about my emulator settings, but I will post my pc specs.

Intel Core i7-3770k 3.50GHz
16 Gigs of DDR 5 ram
AMD Radeon HD 7900 Series with 3gigs of DDR5 memory
Windows 10 64bit

I looked through the forums for a while and didnt really find anything that helped with this problem. If anyone could help at all that would be most appreciated. Thanks in advance! Smile
Reply

Sponsored links

#2
type control panel on the search icon since you got win10 run the control panel app then "system" then press settings in the performance category then set "adjust for best performance"

if random lags remains maybe speedhacks must be disabled.

Xenosaga is one of then using speedhacks on the good rig will cause random lag and cutscene is put out of sync.
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
(02-05-2016, 08:12 AM)smartstrike Wrote: type control panel on the search icon since you got win10 run the control panel app then "system" then press settings in the performance category then set "adjust for best performance"

if random lags remains maybe speedhacks must be disabled.

Xenosaga is one of then using speedhacks on the good rig will cause random lag and cutscene is put out of sync.

Thanks for the response, that didnt work though. I have tried just about everything. Its weird because I had this emulator installed on this computer a year or two ago and didnt have this problem. I just cant for the life of me figure it out. Thanks for the help though.
Reply
#4
Try running in window mode(not full screen)or use DirectX rather than OpenGL
Is that fixes it,then it the forced vsync in OGL full screen mode
Reply
#5
(02-09-2016, 08:59 AM)vsub Wrote: Try running in window mode(not full screen)or use DirectX rather than OpenGL
Is that fixes it,then it the forced vsync in OGL full screen mode

Hey, thanks for the comment. I started fiddling around more, and noticed you could enable vsync in the display options. Funny enough enabling vsync and running it full screen fixed my problem! Weird huh? Thanks again for the help guys, I appreciate it.
Reply




Users browsing this thread: 1 Guest(s)