Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ratchet&Clank 2 Bug
#1
Hi there,

I have a very strange bug in Ratchet & Clank 2 - Going Commando PAL (EU Version).
When I use the Megaturret Glove (Upgrade from miniturret glove) and drop a turret, it's just bouncing up and down, without any other effect.
The bug is 100% reproduceable, it happens every time.
I'm using the most recent dev-build: PCSX2 1.5.0-20181108102600 - compiled on NovĀ  8 2018. For more details of Settings/OS, see attached log.

I played around a little with some Emulation Settings, tried out the presets 1-3, all with the same issue. Also tried SW-Mode rendering, still the same.

In the attached logfile, I started the game, loaded a savegame (from memorycard), dropping a turret and ended the game.

Anyone has an idea what I can do to fix this? Or to help find where/how it happens? Can provide Savestate/Memorycard data if needed, or create a blockdump.

Greetings,

XXXBold


Attached Files
.txt   log.txt (Size: 12,78 KB / Downloads: 125)
Tired of always changing your PCSX2 Configuration for different games?

Check this out: https://forums.pcsx2.net/Thread-PCSX2-MultiConfigTool

Sponsored links

#2
tried fiddling with round mode / clamping mode ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
#3
Known issue on outdated builds. Update to the latest development builds by using the link in my signature.

Edit: ooooooor maybe not..? Will have to check on this.
#4
(11-08-2018, 07:40 PM)jesalvein Wrote: tried fiddling with round mode / clamping mode ?

Just tried out with all combinations. None of them fixes the problem.
Tired of always changing your PCSX2 Configuration for different games?

Check this out: https://forums.pcsx2.net/Thread-PCSX2-MultiConfigTool
#5
Yeah this is a long standing bug. The interesting fact about this is it also happen very rarely on a real PS2 under some conditions but in PCSX2, it's everytime. Please note that this bug affect all versions of the game.
#6
(11-12-2018, 09:46 PM)Atomic83 Wrote: Yeah this is a long standing bug. The interesting fact about this is it also happen very rarely on a real PS2 under some conditions but in PCSX2, it's everytime. Please note that this bug affect all versions of the game.

This bug has not existed in the NTSC-U release since, at least, 1.2.1, and I have failed to reproduce it on 1.4.0, and several 1.5.0 development builds as well.
#7
Hm that's weird, is it possible to switch the Emulator/the game to NTSC somehow? (Doubt it)

But @pandubz, just to clarify, did you use the upgraded version of the turret? The first (non-upgraded) works like a charm.

How can I help best to find/solve the bug? Open an issue on github? Post a blockdump, if yes, where's the best place? Unfortunately, I'm not very good at C++ and not known to the PS2-System, to find sth. in the code directly.

Anyway, very appreciate that there are such activity and reactions on user's problems here!
Tired of always changing your PCSX2 Configuration for different games?

Check this out: https://forums.pcsx2.net/Thread-PCSX2-MultiConfigTool
#8
Unfortunately no, the video mode is baked in to the game.

Yep, my Megaturret Glove is upgraded all the way to Ultra. A blockdump may help, if you could prepare one and link it here I'd be curious to see if playing it back on my end works any better.
#9
(11-13-2018, 06:36 PM)pandubz Wrote: Unfortunately no, the video mode is baked in to the game.

Yep, my Megaturret Glove is upgraded all the way to Ultra. A blockdump may help, if you could prepare one and link it here I'd be curious to see if playing it back on my end works any better.

Here we go. I created one, which contains loading the game, the savestate (from memory card), placing 2 turrets and ending the game.

Unfortenatly it's too big to add it as an attachment here, I've sent you a PM, cause I'm not sure if I'm allowed to paste external download links here.

BTW is it possible to set the output path for the dump-file manually? I needed to start pcsx2.exe as admin, cause it's in the "program files" directory, which requires administrative write permissions.
Tired of always changing your PCSX2 Configuration for different games?

Check this out: https://forums.pcsx2.net/Thread-PCSX2-MultiConfigTool
#10
Hi,
This issue still here, I try to patch PCSX2 1.6.0 to pcsx2-v1.7.0-dev-1158-g690dae5c1-windows-x86, but it's not working, from this 3 years did you find a fix ?




Users browsing this thread: 1 Guest(s)