Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ratchet & Clank (Going Commando) screen glitch
#1
looking at the wiki, it says to switch to opengl software mode to fix the intro glitch (check 1st attachment), but there's slowdown when I immediately get to the 1st room with enemies, and when I pause my game, I get a menu glitch (2nd attachment)

in hardware mode, there's no menu title glitch beyond the background turning completely sky blue (with the exception of a small rendered square in the top left), and there's no slowdown in the 1st room with enemies. there is also a once menu flickering when I load my game, but that's not a problem until something happens; is there a config I can set in hardware mode to fix this background menu glitch and intro glitch without needing to switch to software mode, or not?

using the widescreen patch, computer specs are in profile, and using latest pcsx2 git build


Attached Files Thumbnail(s)
       
Now go help me flame these zombies to canada
Reply

Sponsored links

#2
My recommendation for all the Ratchet and Clank games is to actually not even attempt to use the OpenGL renderers and to use the DX11 renderers instead. This series is the only case where I say this though. There's something fundamentally different about them and for whatever reason the OpenGL renderer, hardware in particular, does not treat these games as nicely as the DX11 renderers do.

I personally just deal with the slowdowns during the cutscenes but if they are FMV's, then enabling "Switch to GSdx software rendering when an FMV plays" in the "Game Fixes" tab of "Emulation Settings" may help you out. The last option is using F9 to manually switch from software to hardware renderers.
OS: Windows 10 Home (64 Bit)
CPU: Intel i7-4710HQ @ 2.5 GHz
GPU: NVIDIA GTX 860m w/ 4 GiB vRAM
RAM: 2x8 GiB DDR3

Oh yeah Red Pandas are cool too.
Reply
#3
I use pcsx2bonus to set my game settings now, so ill try that suggestion (tried spectabis, but it kept crashing when I tried changing one setting in either video, audio, or sound); and just to be clear, I have not progressed past the 1st level of the game, still in the start area

I have the 3rd ratchet and clank game and ratchet deadlocked; before I start those, any game settings you recommend, or just go default?
Now go help me flame these zombies to canada
Reply
#4
I have no idea what pcsx2bonus is, but speaking in terms of the actual settings in PCSX2 and GSdx, for all four of the OG Ratchet and Clank games I run...

EE cycle rate at 300%
VU cycle stealing at 1
MTVU enabled
DX11 HW renderer
3x Native internal resolution
Basic mipmapping

You'll find my specifications in my signature. For all four games, this runs fairly well on my hardware but it is by no means flawless. If there's a lot of stuff going on in the game, you need a fast CPU or it will slow down a bit. But from my experience it's not that annoying or inconvenient. 

Also realized I never addressed the menu glitches. No, I haven't found any way to get around those. I just sorta deal with them because they're menu backgrounds and it doesn't bug me that much.
OS: Windows 10 Home (64 Bit)
CPU: Intel i7-4710HQ @ 2.5 GHz
GPU: NVIDIA GTX 860m w/ 4 GiB vRAM
RAM: 2x8 GiB DDR3

Oh yeah Red Pandas are cool too.
Reply
#5
I am trying out your settings, and so far, the graphics took a major improvement, being more clear and less ps2 clunky, but quite a bit of slowdown when I moved into the room with the 2 saw-bots and the one flamethrower-bot; when I look outside to my right, seeing the engine flames slows down my game, and continues when I press forward outside

also, pcsx2bonus is a pcsx2 frontend; you configure it to detect the directory where pcsx2 is located, drag n drop the iso files of your games onto it, and from there, you can mess with it, even set your own custom settings for each game (separate from main pcsx2 settings) for audio, video, and input plugins; though, if you use it, click on the edit button, settings, and uncheck download game information before adding games, not doing so will see you temporarily IP banned everytime from gameFAQ's if you go there or have an account
Now go help me flame these zombies to canada
Reply
#6
The slowdown internally is normal, it's always been like that unfortunately.
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]
Reply
#7
Yeah there's not really much to be done other than crank the EE and hope your CPU can tank it. That first level is a real offender though, they had a field day with particle effects, lights and whatnot. I'd argue it's probably the worst performing level in the game, really. There are definitely other spots throughout, but I promise it gets better.
OS: Windows 10 Home (64 Bit)
CPU: Intel i7-4710HQ @ 2.5 GHz
GPU: NVIDIA GTX 860m w/ 4 GiB vRAM
RAM: 2x8 GiB DDR3

Oh yeah Red Pandas are cool too.
Reply
#8
with the "switch to sw mode during cutscenes and back when done" enabled, the title screen glitch went away, but it seems to have a bit of a problem immediately switching back to hw mode

example: I boot the game, it switches to sw mode during the game intro, screen glitch from 1st attachment is non-existent, load up save (menu is fully loaded, no flickering, nor missing background), load into first "tutorial" area, stays in SW mode

I have to go into the gsdx settings, and click ok to switch back to HW mode, but i think it breaks the earlier gamefix by doing this, doesn't auto-activate until rebooting pcsx2
Now go help me flame these zombies to canada
Reply




Users browsing this thread: 1 Guest(s)