Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ratchet and Clank Frame Limiting
#1
Hey,

I'm trying to play R&C2 and it nearly works... I've been messing around with it for some time now and I think I nearly have the settings perfect... but not quite.

Basically, at times I was getting lots of lag - then I found out about frame limiting.

It turns out, if I enable frame limiting, the game speeds up dramatically. In fact, it goes TOO fast! So it seems to me my computer is obviously capable of running the game at a good speed, it just doesn't know what speed to use...

Can anyone give me any insight on this?

Thanks,

Boggy
Reply

Sponsored links

#2
tl;dr: how can I keep the game running at a constant, non-laggy speed?
Reply
#3
Well you probably had no reply yet, couse it's a bit illogical what you wrote. Framelimiter as it's name says LIMITS fps, soo it set's max fps and doesn't allow any more - quite the opposite of what you say. Framelimiter has 3 states through, "Normal", "Slomo" and "Turbo" which you can see at the top of the window where game renders after "Limiter:", well to be exact it also has "None" state - which obviously means it's turned off.

By default, slomo is 50% speed, Turbo is 200% speed, I guess I don't need to say % of normal;P(you can change those speeds in emulation settings->GS. You can toggle turbo/normal with TAB key or slomo/normal with shift+TAB key combination and switch framelimiting on/off(normal/none) by F4 key.

Soo with frame limiting, make sure it's set as "Normal" to play at full/normal speed and make sure it's not on turbo when you are experiencing higher speeds nor slomo when you have lags.


Other than that, if you still have problems with speed, would be nice if you actually wrote what hardware you have in your system. Mainly CPU model/speed and GPU model, nothing else really matters much for pcsx2. And also your EE/GS% while playing, especially when it lags, which you can see at the top of the game window. And last, but not least which pcsx2 version you're using. Such little info will greatly help us to guess what's actually happening there.
Reply
#4
Probably he wanted to say by Enabling the 'Disable Frame Limiting', the game runs fast. Tongue2.

@Boggy : Read the options before posting... Tongue2

Ratchet and Clank is very slow. Download the PCSX2 Buildbot SVN PCSX2 SVN, and use the MTVU Hack. Better Overclock your CPU.

By disabling the framelimiter the fps is rendered to its max possible speed(sometimes 600 or even sometimes 50 fps) . Change the base framerate to 140% or 150%.

As said by Miseru99,

What are the EE/GS% percentages when you get slowdown. If it is GS, then enableing the frame skip would help a lot. Enable the Speedhacks and set the EE cycle to 2, and VU Cycle to 1.
Reply
#5
try using native res. First....if u get full fps then use custom res and increase till a point where u get playable fps.....also pls specify ur system info.....and neglect frame skip as it might possibly slow down your game
Reply
#6
Thanks for the replies.

(10-15-2011, 07:57 AM)recoder Wrote: Probably he wanted to say by Enabling the 'Disable Frame Limiting', the game runs fast. Tongue2.
That's probably it.

Quote:@Boggy : Read the options before posting... Tongue2

Ratchet and Clank is very slow. Download the PCSX2 Buildbot SVN PCSX2 SVN, and use the MTVU Hack. Better Overclock your CPU.
I've done quite a lot of reading and have adjusted the options as well as I know how, but it seems there's still much I don't understand. I know R&C tends to be slow, but if my computer can run it at "turbo speed", why does it lag at normal speed? I'm sure it ought to be able to handle it.

I'm intrigued by this "Buildbot SVN"... what's the difference between that and pcsx2-r4600, which I was using before?

(10-15-2011, 03:54 AM)miseru99 Wrote: Other than that, if you still have problems with speed, would be nice if you actually wrote what hardware you have in your system. Mainly CPU model/speed and GPU model, nothing else really matters much for pcsx2.

Intel i7 2.0 GHz
NVidia GeForce GT 540M

Is that adequate?

Quote:What are the EE/GS% percentages when you get slowdown. If it is GS, then enableing the frame skip would help a lot. Enable the Speedhacks and set the EE cycle to 2, and VU Cycle to 1.

And also your EE/GS% while playing, especially when it lags, which you can see at the top of the game window. And last, but not least which pcsx2 version you're using. Such little info will greatly help us to guess what's actually happening there.
I'll get back to you on this after having a bit more of a play around, particularly with this new build...

(10-15-2011, 09:02 AM)XcaliburXI Wrote: try using native res. First....if u get full fps then use custom res and increase till a point where u get playable fps.....also pls specify ur system info.....and neglect frame skip as it might possibly slow down your game
I've not been using frame skip. I think I'm using Native resolution (the box is grayed out in "Plugin Settings", but it is checked.

I appreciate all your help Smile
Reply
#7
Boggy Wrote:but if my computer can run it at "turbo speed"

Change the base framerate to 200% to get an exact speed of turbo mode.

Turbo runs the game in 200%. and Base at 100%. So changing the Base to 200% would be same as Turbo.

Boggy Wrote:I think I'm using Native resolution (the box is grayed out in "Plugin Settings", but it is checked.

Native resolution box is grayed out....? What are you mean?
Reply
#8
Boggy Wrote:I'm intrigued by this "Buildbot SVN"... what's the difference between that and pcsx2-r4600, which I was using before?

BuildBot SVN's have another Speedhack called MTVU Hack, which makes the VU on a seperate thread, and thus makes the PCSX2 work much better. (and faster Tongue2)
Reply
#9
(10-15-2011, 02:35 PM)recoder Wrote: Change the base framerate to 200% to get an exact speed of turbo mode.

Turbo runs the game in 200%. and Base at 100%. So changing the Base to 200% would be same as Turbo.
I see... So I could increase the base framerate to fix the jerkiness, but then some parts would go too fast Sad

Quote:Native resolution box is grayed out....? What are you mean?
I am using a software renderer in "Config > Video (GS) > Plugin Settings", which apparently means I am unable to select "Native Resolution".

Also, how would increasing the number of Rendering Threads affect the speed?

(10-15-2011, 02:51 PM)recoder Wrote: BuildBot SVN's have another Speedhack called MTVU Hack, which makes the VU on a seperate thread, and thus makes the PCSX2 work much better. (and faster Tongue2)
I see! Why isn't this in the downloads section? It seems better already!

Having played with the new build, I'm getting less slowdown than before, but still some at times. Here were the numbers from the title bar at once point of lag:

EE: 39%
GS: 100%
VU: 10%
UI: 1%

Another time (it's quite hard to pinpoint exactly...):

EE: 41%
GS: 53%
VU: 4%
UI: 0%

What does this mean?

Thanks again.
Reply
#10
Boggy Wrote:Also, how would increasing the number of Rendering Threads affect the speed?

By increasing the number of rendering threads, the Graphics plugin will use more threads and thus the load of graphics will be less on each thread, and thus more load can be efficiently taken.

Well, Software mode is very slow. Better use the Hardware Mode(which is faster), and use may see some boost
Boggy Wrote:I see! Why isn't this in the downloads section? It seems better already!

PCSX2 SVN are of versions PCSX2 0.9.9. Well, PCSX2 0.9.9 is not yet ready and it will be released when the PCSX2 0.9.9 with the MTVU Hack and probably with soem more features will be ready and tested.
Reply




Users browsing this thread: 1 Guest(s)