Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rebinding Keys not working
#1
I bought a new computer, and the keyboard has controls that change volume, brightness, etc. all set to the function keys. Trying to use them with PCSX2 running just changes the volume, brightness, etc. I tried using the PCSX2_keys.ini (moved to PCSX2/inis_1.4.0 where the other .ini's are) but my changed keybindings don't seem to work. I was only attempting to change the F8 key for screenshots to KP_ENTER, but I soon realized I would have to change all the others to control savestates and such.

What would be the reason for why the changed keys aren't working? Alternatively, could I somehow disable the keyboard controls while PCSX2 is running / make the F keys work properly in PCSX2? Double alternatively, does anyone with similar keyboard issues already have an .ini with changed keybinds? Please advise.
Reply

Sponsored links

#2
(12-03-2019, 10:54 PM)El3mental Wrote: I bought a new computer, and the keyboard has controls that change volume, brightness, etc. all set to the function keys. Trying to use them with PCSX2 running just changes the volume, brightness, etc. I tried using the PCSX2_keys.ini (moved to PCSX2/inis_1.4.0 where the other .ini's are) but my changed keybindings don't seem to work. I was only attempting to change the F8 key for screenshots to KP_ENTER, but I soon realized I would have to change all the others to control savestates and such.

What would be the reason for why the changed keys aren't working? Alternatively, could I somehow disable the keyboard controls while PCSX2 is running / make the F keys work properly in PCSX2? Double alternatively, does anyone with similar keyboard issues already have an .ini with changed keybinds? Please advise.

I have no idea how PCSX2_keys.ini is supposed to work but if you want this to work system wide, you will need to change a setting in your PC's BIOS. Most laptop BIOSes will have a setting to flip the primary function of the F keys between the special features and the normal F numbers. Some desktops may do this as well. If nothing else, look for a Fn key on your keyboard, and hold this to manually toggle the mode.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply




Users browsing this thread: 1 Guest(s)