Repeating black flicker
Hey everyone.

I'm running .9.7 of PCSX2, and whatever settings I seem to do, i receive a periodic (about every 10-20 seconds) black flicker, almost as if a frame is being skipped, but its quite obtrusive and ugly.

This is on GSDX (any) and when i'm using any hard wear or soft setting and no matter what interlace option i choose. my fps is always at 60, so i'm kind of stumped as to why this problem persists. Frame skipping is set to off. Also, I googled a similar thread earlier, and turning off vsync from the nvidia panel had no effect, as well as 'turning off aero' (which im assuming is the preview window on transparent windows 7 i'm using?) unless i'm turning it off wrong, i thought you went into personalize-> and clicked on a basic/high contrast theme.

I'm running on an i5 2500k oc at 4.5hz, gtx 570, 4gb ram, windows 7, updated direct x; pretty much all new *****, all my modern games run perfect, its just this emulator that is giving me trouble.

Games I've got this problem on are all that i've tried; odin sphere, ar tonelico 2, ZoE 1.

Thanks for taking the time to read, as I'm at my wits end after a long night of reading the configuration guide up and down and google'ing to no avail.

Sponsored links

How about with PCSX2 0.9.8?
Yep, new version is the same damn thing. I even run it on the ***** GSDXs for my processor and it seems to still give me the flicker. Maybe it is that 'aero' thing, but it didn't seem to fix it when i changed my settings..
Also make sure you use DX10 rendering.
I remember having a flickering problem in an older rev with some games,
and simply pausing, then resuming emulation fixed it.

I suppose we couldn't be so lucky here...

If nothing else, maybe try the latest SVN.
i'll mess with stuff some more before resorting to frapsing some kind of video as a last resort, thanks again.

any chance a corrupted bios i use could be the issue? whats weird, is that it seems to be not a problem with the settings but something else..i don't know, no setting really affects it in terms of fps, and some of the interlace options only affect the quality/add shaking.
I doubt it's the BIOS, for me that's one of those things that works or it doesn't, but if your not sure you can always re-dump a fresh copy from your PS2. I think (but I'm not sure) once the game is launched, it provides it's own IOS. perhaps you have some sort of unknown hardware issue, a bad video driver or something+^_^+
Signature purposefully left blank.
I did two things that made a change: i set my nvidia vertical sync to 'force off' and i changed windows theme to 'original/basic' and now the flicker has a longer interval (20-30sec) and it only happens to the bottom half of the screen instead of the whole.

any ideas? i think my video drivers are fine but ill see what i can do there.

[EDIT1: included some screen caps. changing the D3D internal res under GSDX seems to have literally no affect, strangely, and the games resolution under window GS never changes despite what values i enter in it, unless i hit 'wide screen' for example. it seems to be fixed at that 1118 x 837 value i think..]

Attached Files Thumbnail(s)
Odin Sphere is mostly a 2D game, so you don't notice the increased upscale resolution much (watch the weapon though, the tip is 3D).
The flicker you get is still uncommon but I advise you to set the scaling back to x2 or x3, just to avoid problems later.
the resolution in GS window changes how large the display window is on your physical monitor and has very little if anything to do with the Emu resolution (window size is maintained by OS) anyway, shutdown the emu before changing those values and you should see an effect afterwards, another thing you can do is close the Emu settings window, grab the edge of the game window, re-size, and when you re-open emu settings page, the GS Window res should be different+^_^+
Signature purposefully left blank.

Users browsing this thread: 1 Guest(s)