Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Repeating black flicker
#11
Alright, thanks for the tips.

I decided to run it under zerogs, and it's stopped the flicker issue.

at an AA higher than 2x i witness some fps fluctuation and random lines that appear, so i stayed away from the higher settings.

i left binary and interlace on, and im running it at 1280x960.

any settings you'd suggest for my build (gtx570, 4.5ghz) i don't mind the current size..but..oh well.

on a side note, odin sphere pretty much looked in the same in zero, but when i put in ar tonelico 2 the sprites were much less detailed, and had ugly think black borders around them which looks pretty awful in combat. also, any AA setting period would cause severe distortion/all sorts of ***** going wrong. yet, even on no AA there is lots of bugs when it comes to the combat scenes, sprites going in visible, cracking, etc. im guessing this is not intended..whether i wish to live with a black flicker or not. sigh

ps: i will not update my driver to the latest nvdia one (mines one version behind) because i looked on the forums and there is all sorts of ***** storm about how terrible the newest driver is, casing all sorts of system instability and higher graphic temps, etc.

1st pic is comparison

2nd: anything from the GPU settings that might help?


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#12
In that GSdx screenshot you have bilinear filtering disabled.
Either put the checkmark for it back to half ticked or if you're not sure, delete the GSdx.ini to revert to defaults.
ZeroGS isn't developed anymore and has several glitches.
Reply
#13
I'm having the same problem here, it's only gsdx causing it. I don't get it at zerogs either...
I tried all the different setting and still get the flickering on every game I try. it's driving me insane. changed my 3d setting of my card to no avail.I remember I didn't have this problem in earlier version of pcsx2 I think but could be wrong.I got my pc hooked up to my 42" LCD. could that be the problem?
It's really weird, I don't have any problems with any other emu's or games.
My card drivers are the latest. I'm using the latest SVN.

-EDIT: To be sure, I tried using the old gsdx version used in pcsx2 0.9.6 and what do you know.. absolutely flawless.. no flickering encountered at all.. too bad the fps is so bad because the version is so old.
Anyway now atleast we know newer versions of gsdx are causing this problem.

-EDIT 2: I've narrowed it down a bit more. GSDX versions up to 0.1.14 don't give me any flickering.
The problem seems to have started in version 0.1.15 and hasn't been fixed.
Reply
#14
This is most likely some setting that goes bad for you two, not an emulation error.
My best guess is an issue with Vsync but I can't really tell unless I see it myself.
Try switching renderers from DX10 to DX9, both hardware and software, see if it changes.
Also make sure to disable Vsync in PCSX2's GS settings tab.
Reply
#15
(04-30-2012, 07:17 PM)rama Wrote: This is most likely some setting that goes bad for you two, not an emulation error.
My best guess is an issue with Vsync but I can't really tell unless I see it myself.
Try switching renderers from DX10 to DX9, both hardware and software, see if it changes.
Also make sure to disable Vsync in PCSX2's GS settings tab.

I've tried every setting possible at this point.disabled all the settings of my gpu, disabled aero.
I'm trying to find out why i'm not getting the issue in earlier gsdx versions or in ZeroGS, but can't seem to find the reason, also the problem doesn't seem to show if you record it =/.
I've been trying to track down in which revision this began but having a hard time.
I think it' started somewhere around 0.1.15 r2000.
Reply
#16
What OS are you using? Please keep aero on, as the disabled modes are using fallback code that's prolly not working well.
Reply
#17
(04-30-2012, 08:22 PM)rama Wrote: What OS are you using? Please keep aero on, as the disabled modes are using fallback code that's prolly not working well.

Windows 7 Ultimate x64. Latest updates. Latest Directx .
Also I turned aero back on because I noticed some slowdown indeed.
I tried just living with it but it's starting to be uncomfortable on the eyes.
Reply




Users browsing this thread: 1 Guest(s)