Replacement bluetooth dongle doesn't pair, but ONLY on desktop
I've been beating my head against this issue for a few hours now. Just recently, my Sabrent bluetooth dongle died on me. I got a replacement, same make and model. After doing a clean install of the SCP DS3 drivers and services on my laptop, everything works fine. However, after doing a clean install on my desktop, my controllers fail to pair with the dongle.

What's interesting is that when plugged into my laptop, the DS3 Monitor reports a HCI and LMP version of 5.39321. DS3 Monitor on my desktop, however, reports a HCI and LMP version of 3.3164. Also, the MAC address of the dongle is different on my laptop compared to my desktop.

Both computers are using Windows 10. The desktop is using 10 Pro, the laptop is using 10 Home. Again, the old Sabrent dongle worked perfectly on my desktop, so it shouldn't be an OS issue. The new dongle is working perfectly on the laptop, so it shouldn't be an issue with the dongle itself.

[Image: 9zLjv19.png]

[Image: ubeg4jP.png]

I've tried just about everything I can think of, from uninstalling through the SCPDriver executable then force installing, to uninstalling the drivers through device manager, manually pairing, rebooting, using a different PS3 controller, and any combination of the 5 in different orders. I've also tried 3 different versions of the SCP Driver package, all of which had the same result. I'm fresh out of ideas here.


Sponsored links

Users browsing this thread: 1 Guest(s)