Requesting assistance re: F310 gamepad in Linux Mint ...
Hi, everyone - am running Linux Mint 19.2 (Cinnamon Edition).  (Love MINT!)  My Logitech F310 gamepad is wonky in PCSX2.  I have PCSX2 installed with my own legal BIOS and copies of my own games.  I have PCSX2 1.4.0 (stable), which I obtained from the "official" PCSX2 PPA for Linux repositories.  PCSX2 has no problem running games.  However, the gamepad is wonky, as I mentioned.  When I bind buttons, analog sticks, and the directional pad in the plugin setup screen (for the controller), everything works.  PCSX2 detects all of the inputs just fine.  (I should mention here that I am using the ONE PAD 1.1.0 plugin that comes with the "official" package from the PPA.)  BUT when I start up a game, the left analog stick and the directional pad are wonky.  In games where both the analog stick and the directional pad are supposed to work (e.g., Metal Gear Solid 3), they don't.  I can't move anyone.  The right analog stick works fine.  The buttons work fine.  When I switch between "modes" on my gamepad, sometimes I can only use one or the other.  The gamepad is set to Xinput (on the back of the gamepad with the switch that goes between Xinput and Dinput).  Help!  Thanks!

Sponsored links

UPDATE: Uninstalled PCSX2 via Synaptic Package Manager.  Found out about a program called "jstest-gtk."  It was able to detect my F310 gamepad just fine.  Seemed to pick up on all the button, analog stick, and directional pad inputs.  I calibrated the gamepad.  Reinstalled PCSX2.  Configured the gamepad in PCSX2.  Worked fine.  Games tested included Metal Gear Solid 3, Shadow of the Colossus, Maximo, GTA: Vice City, NBA 2K11, and VF4: Evolution.  Everything apparently works now.  Weird!  Anyway, hope this helps someone else later on if they find themselves in the same spot.

Users browsing this thread: 1 Guest(s)