Resolved: [Bug Report] Ace Combat 04 (NTSC-U)
#1
Emulator v1.7.2589
Windows 10 21H1 Build 19043.1645
Ryzen 3600XT
16GB RAM @ 3200MHz
GTX 1080 w/ Driver 511.79
using asasega's deinterlace patch (wasn't able to link)

While in third person, the player's plane is completely black. I've noticed this is affected by the chosen renderer and level of blending accuracy.
In DirectX 11, the plane is black on "high" and above.
In OpenGL and Vulkan, the plane is black on every setting except "minimum".

To reproduce, load into a mission and switch to the third person view by tapping down on the d-pad. Change renderer and blending accuracy settings. Plane will either be textured or black.

Note: the plane is always black without the deinterlace patch

Sponsored links

#2
can you please give stable 1.6 a try ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
#3
(04-14-2022, 11:23 PM)jesalvein Wrote: can you please give stable 1.6 a try ?

Did my best to recreate my 1.7 settings. On stable 1.6, Direct3D is fine on all settings and OpenGL gives a black plane on all blending settings except "None". Still always black if not using the deinterlacing patch. Included inis.zip is for 1.6.

Decided to test on the newest 1.7 version (2613 as of now) to give it a shot and Direct3D 11, OpenGL, and Vulkan are the same as before. Direct3D 12 was interesting. It looks like the plane is trying to cast a shadow on itself, but the shadow is glitched. From minimum-medium the shadow looks like this: 
   
and from high and above it looks like this:
   


Attached Files
.zip   inis.zip (Size: 6,64 KB / Downloads: 126)
#4
Can you upload a gsdump of the issue?
#5
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.
https://github.com/PCSX2/pcsx2/pull/8826

This thread will now be closed and moved to the resolved bug reports subforum.




Users browsing this thread: 1 Guest(s)